Alarm 2 when doing test run

gSender 1.1.7
Limit switches installed

  1. Home Machine
  2. Set XYZ zero to top of material lower left corner
  3. Perform Test Run and gSender immediately throws an Alarm 2.
  4. Reset Z to high above work surface for a test run.
  5. Press Start Job and everything seems to run OK. It just doesn’t seem to want to do the test of the gcode. I’m afraid to actually cut the piece just incase there’s something goofy somewhere down the line in the code.

The outline function works too. I’m baffled.

What have I done wrong this time ?




Here’s the first bit of gCode that VCarve Pro produced.
I’m wondering if it’s choking on the T1 command.


Another Edit:

If i disable Soft Limits then the Test Run Works.

Some more information.

The material is 3/4" thick. The Test Run quits when Z gets to the bottom of the workpiece. As far as I can tell this is where the file quits: G1Z-0.7500F12.0. gSender says line 57 so I’m assuming that it doesn’t count lines outlined by ( ).

I tried another version of the gcode and it quit at line 791, where a inside profile reaches the depth of 3/4".

So I’m assuming that the soft limits are triggering when the cutter reaches the bottom of the workpiece.

This project also uses 1/4" and 1/2" materials. They also use similar drilling, inside profiling and outside profiling operations. The files for the 1/4" and 1/2" material all successfully pass the Test Run in gSender. I’m leaning towards it being a problem with the 3/4" depth of cut.

I’m using an 1/8 DC Endmill. Is there a setting that specifies the maximum depth of cut in VCarve Pro of a particular tool? I can only find the diameter of the endmill in the tool database not the cutting length. In the toolpaths I have the start depth at 0 and the cut depth at .75 and the software automatically chose 13 passes.

I created a single toolpath of a larger outside profile so I could see when gSender quits in the Test Run mode. It made a 13 pass cut with the 1/8" EM. It made every pass except the last one where gSender drops the Alarm 2.

Thanks again.


Stuart, in VcarvePro your toolpath is where you make temporary (limited to this toolpath) adjustments to your tool. Use the EDIT button where you select a tool for that toolpath. It will look like the tool database with most of the same fields to adjust, but it won’t make any changes to the database. These are changes specific only to this toolpath.


I found that OK, it just seems that the cutting length of endmills isn’t available. Anyway, I tried with a 1/4" endmill and still ran into the same issue with the Test Run. It quits and throws the Alarm 2 when it gets to the last path.

I did just turn off soft limits and ran the job. It ran perfectly, it just fails the test run.


I’m using a Shapeoko, so there are no limits! :smiley: At least, there are no alarms. I find that I don’t use the test run “feature” of gSender, but I do use the outline feature.

But, after re-reading your message, I’m not sure if you are looking for a maximum limit on cutting or a reminder of the cutting length of an endmill.

The former is controlled in your toolpath. Of course, you have to know what that length is and conform your cutting to it.

The latter can be done in the description of your tool (endmill.) There are variables that you an use in naming your tool, but you can also just add text similar to “TPL=0.750” as a reminder. And, again, that is really only useful during toolpath creation.

This shouldn’t matter as soft limits are measuring distance from the limit switch. Are you using the same endmill?
Can you jog to your wasteboard?

1 Like


The job is only about 5.5x14x3/4". It was positioned well inside the available cutting area. I can jog all around the project with no problem. Like I said before, I can do the outline function no problem, it just won’t do the test run once the cutter reaches the last pass depth.

I did actually do the cutting by turning the soft limits off and it worked perfectly. I’m stumped as to why any project 3/4" or greater won’t pass the test run with the soft limits on and limit switches installed. Maybe I have one of the firmware settings wrong.

BTW I’m using the same 1/8" endmill for all the parts, 1/4" to 3/4" thick, and the endmill is set in the collet far enough out that it will cut into the waste board.


And now it’s quitting with any thickness job.

Now I feel it’s a setting I’ve goofed up.

I’ll post the firmware settings once this current job finishes.


Firmware settings
20-22 are enabled.
23 enabled, x &y on , z off.
132 105mm.

Disable soft limits for now.
What’s your machine position when your endmill is at the wasteboard?

After homing the carriage is all the way up and to the left and the Y is all the way to the front. For I’ll set XY zero at the home position and Z to the top of the wasteboard.

With the endmill in the router and the Z down until it touches the wasteboard gSender is reporting Z as 0.000 for the top number and -4.026 for the bottom number. My wasteboard is smaller than the cutting area right now and the X position for the left edge is 4.000 for the top number and 4.000 for the bottom number. The wasteboard extends out the front of the cutting area a bit so it’s full forward travel is reporting 0.000 for the top and bottom numbers.

Assuming inches. That’s a little short of your 105mm. A shorter endmill would give you trouble.
What’s your $13 value?


I’m on the road till Friday. I have no idea what the $13 value is.

I’m working on a theory. I think the soft limits are preventing the cutter from going into the waste board. I actually got the test run to work. I reset the Z to the top of the project and it worked. I think it works because the material is slightly over 3/4” in the spot I probed Z. When it fails I think the area I’m probing is slightly less than 3/4”. I think that’s why it initially worked with the 1/4” and 1/2” material because I just ran the simulation with Z set for 3/4” stock, but it failed after I set Z to those dimensions. My stock might be slightly under what I’m telling the machine.

I’ll do a short test run next week when I get home.