Bitsetter help setup

I have a shapeoko pro that I just started using the gsender program instead of carbide motion.

I have searched and read about the bitsetter but for the life of me cannot figure out how to get this to work with gsender.

I downloaded this file: gSender-macros-BitSetter.json but cannot figure out where to either put this or how to load.

Some hand holding to get this running would be much appreciated.


In the bottom right panel of GSender on the Macros tab there is an import button. I think that’s how you load a macro.

Pete, did you figure this out? I also downloaded the macros but can’t figure out how to import them into gsender. I click on the ‘import macro’ icon but gsender doesn’t ‘see’ the file I want to import. Perhaps the macro is in the wrong file format?

@Troles you can feel free to share the macro file here if you’d like help looking at it. Alternatively we’ve got a new toolchange option in the settings for a fixed tool length sensor like the BitSetter where theoretcially you won’t need any macros anymore - they’re newly added but may do what you’re looking for, if you want to do an initial test I’d stick a broken bit in in case something goes wrong

Thank you Chrismakesstuff, it is really a “general” and “specific” question. (fyi, I use a Ras. Pi with gsender 1.7) Generally, I do not understand how to import a macro. I click on the import in gsender, and a window opens in gsender to search my computer for the file to import. I can find the file I downloaded (zip format) but it does not let me click on it and add it. I tried to unzip it, and it still does not let me add it. It is like it is not in a file format that gsender accepts. So, I tried to do it the hard way, I opened the dowloaded macro and viewed it in a wordpad/notepad/text editor format and copied it and then went to gsender and tried to just create a new macro and paste it in, but it will not paste in. The macro is very long so i did not want to try to type out all the macro code. So, the first general question is how specifically to import a macro (what file type is needed, etc.) as i don’t see anything in the forum,e tc. that details that. The Second/specific question is you asked to “share the macro here for help looking at it”… I don’t have an issue or question with the actual macro, it is NeilFerreri’s bitchanger macro that i feel confident is written well. I just can’t get it into my gsender. Lastly, I know your new gsender has this built in, but I just haven’t felt ready to upgrade it yet, and more generally, just want to figure out how to import macros in general for future use. Hope that all makes sense.

1 Like

The macro file needs to end in “.json”, if you search the forum you’ll see that Neil posted a version of his macros that are able to be downloaded by gSender. Also, I’m not sure which version of gSender you’re using but you should be able to copy and paste the g-code in if you need to, I just tried it myself and it seems to work

I understand you’re trying to figure out the process so I’m happy to answer any more questions to get it figured out for you. If you successfully get the “.json” file, gSender will be able to import that just fine.

So, for any others who may have this issue, I have figured it out and will post here the issue. As you can read above, I was having trouble importing a macro into Gsender (fyi, I am using 1.1.7 version, on a raspberry pi) I am not very good on Pi/linux, so the problem was my mistake. Download the macro you want first. In this case, it was the Neil Ferreri’s bitchanger macro, which is in a json format. Then click on “import” macro in Gsender. Here is where the problem came for me. When you click import macro, a window opens up in gsender and you try to find the file you want to import. For me, it was in my “downloads” folder. But when I clicked on downloads folder, it was “empty” and nothing to select. This was because in window, in the bottom right, there is a dropdown box to choose “all files” or “custom files”. Mine was default to custom files, so nothing showed up. When I changed to “all files”, the macro was there, I selected it, and it imported great into Gsender.

Also, on the other method I mentioned above, I also figured that out. When I tried add the macro (not by import) by just creating a new macro and cut/paste the info in, it didn’t work. This is because for me (in gsender on a Pi), it didn’t let me just “right click in the box and select paste” (like i do in windows and other programs). Well it does work, but you have to actually do “control/v” with a keyboard. I didn’t have a keyboard set up the first time, so didn’t try that. With a keyboard, it does let me copy paste text/data into a new macro window.
Hope this helps someone down the road…let me know if any questions.