Can unshelded wires/elecrical interferance cause UGS to disconnect from the longmill

I’m still really new to all this but I finally got up and running with my first project. Just a little way into my first cut UGS froze and disconnected. When I tried to reconnect I would get “serial port not found”. After closing and reopening/trying to connect multiple times I finally got back to work. This happened about 5 times, usually failing/disconnecting around the same point. I ran the same g code without cutting any wood a few times and it ran beginning to end with no issues. It was only when cutting a piece it would disconnect.

Anyway I got to looking around and found this thread:


About 3/4 of the way down someone suggests its a hardware issue, not to zip tie certain wires together and to try and shield electrical equipment. I also read in another thread static electricity from a shop vac hose might interfere.

I had my wires zip tied together so I separated them and I got through 1 piece without UGS disconnecting. It seemed like it might have worked or am I crazy? Has anyone else had this UGS disconnect issue?

@will You’re not crazy, Will. :slightly_smiling_face:

Do a search here using “UGS freezes” and you will find several posts discussing this and offering solutions.

I went through this a lot when I first started with my Mill. I haven’t had any type of freeze now, though, for months. I did many things, so unfortunately I can’t say which of them fixed the problem. The one exception to that was grounding my dust collection PVC pipe. I had been fine for a while, then changed my dust collection set up. Immediately after, I started getting freezes again. I grounded the system and all was well again.

Here is a list, as much as I can recall, of what I and others did to solve UGS freezes:

  1. If you replaced the included USB cable with something longer, make sure that it has good noise filters/chokes on it.

  2. If you are running the old August 2019 version of UGS, update it to the latest 2020 version.

  3. Be sure to ground your dust collection system.

  4. If you are using a Windows PC to connect to your Mill, be sure to disable all the power settings for USB and sleep.

  5. Don’t run your gcode from a USB stick. Copy the file to the drive on your PC. (Others will argue that they use a USB stick all the time with no issues.) I think this may depend on the USB version your PC is running. The old USB 1.1 is pretty slow, for example.

There may be other remedies that I’ve forgotten. I’ve done all these things over time. Some here have said that they’ve done pretty much none of them and had no problems at all with UGS. I don’t doubt that, but since I had problems, I looked for and found solutions.

2 Likes

Thanks for the advice. So far I’ve

  1. Grounded the dust collector
  2. Switched over to a higher quality surge protector
  3. Updated my usb settings
  4. Separated all my wiring and running the router off another outlet

It’ll run beginning to end with the router/dust collector on. Its only when its actually cutting does it freeze up/disconnect. Is something different when the system is under load? Is it possible to overload it?

In the thread I was reading it ended up being the USB cord. The one that came with the machine seems good but I don’t know a lot about USB cords. Would that make sense?

@will I don’t recall reading of anyone who solved the freeze problem by replacing the stock USB cable. I replaced mine only because I needed a longer one for my setup. I can’t see how the cable would be the cause only when the Mill is under load, but I suppose anything is possible.

I can’t see how it would be possible to overload the system. If the router is bad or pulling too many amps, I would think that it would pop a breaker, but that may be something to look into. What router are you using?

What version of UGS are you running? If you are not running the August 2020 version, I suggest that you try it. Other than that, I’m out of ideas. You seem to have done everything that I had to do to resolve the issue for me.

Thanks, Ill try the latest version tonight. I was using it but I switched to the older version thinking it was more stable. In case someone is reading this in the future, I also switched UGS drivers which didn’t help. Im using the makita trim router that came with the mill. Maybe under load the router causes more interference which causes UGS to go offline?

At the very bottom of the thread I attached the guy closes the loop by saying he switched USB cables and the problem went away. I ordered a double shielded cable that will be here friday. Hopefully that works, if not I’m out of ideas.