Disconnection issue

Good day Everyone,

I am having some issue this weekend with my CNC, basically I lost the connection from my PC to my CNC. the same problem happen with my MacBook Pro and my 2x surface tablets using UGS and CNCjs. My machine has been running fine for the last few weeks/month.

here what I have done so far…

  • vacuum completely disconnected and put away;
  • router unplugged;
  • all wires that were strapped together are undone now;
    -no power wire and signal wire mixed together;
  • I disconnected everything from my control box excepted my laptop connected and everything works fine. no disconnection. (virtually i can move my x, y and z axis without any issue);
  • gamepad disconnected
  • I tried different USB cable, same problem.
  • I tried different power source, same problem.
  • I try to run the laptop only on battery, same problem.

now here what happen…

  • as soon as I plug in one of the step motors in the control box, if I try to move the cnc, x,y and z, it doesn’t matter which one…my computer get disconnected.
  • I plugged in one motor at the time, trying all the port… same issue every time.

so I think the issue is the actually controller box.

tomorrow I will open the box to make sure nothing is loose inside…

I need some help please…

Thank you,

JF

@jefflem Welcome, Jeff. I may well be limited to just welcoming you, as this is a strange one. I assume that when you are testing it with a motor connected, you have the power on to your controller. Can you see the driver board lights? Are they all powered up?

Yes exactly, everything has power, the light is on … i tested it this morning again … if i do a 0.1mm or 100mm step … the controller disconnect itself … doesn’t matter if only 1 or all 4 motors are connected … and it does it even if i only connect the x axis motor for exemple and i move the z axis (no motor connected) with the software… it get disconnected as soon as i try to move it

@jefflem The only other thing that I can think of is USB power. Make sure that you have windows set to NEVER adjust power to the USB ports.

all the usb ports has been change so they do not shut down, all my setting were correct and i am having those issue

@jefflem I’m out of ideas, Jeff. Sorry. I would contact Sienci support.

yes this is what I did this morning, hopefully they can figure it out if not they will send me a new controller box, I even reflash the Arduino board this morning and didn’t change anything

thanks for your help much appreciated,