Firmware setting for a Queen Bee machine

Hello everybody. I have a Queen bee machine with CNC prov-5 controller. I have been using CNCjs but having some problems with it. I saw gSender and thought I would give it a try. Downloaded great, jogs fine, homes only by $H. How do I Input My Machine info in firmware. I am using the generic cnc but nothing shows for EEPROM settings. Can’t seem to get Homing button to show up. Can anybody help?

Welcome to the group, Fred! I’m not sure how to fix your problem but wanted to say that I think the profile at the top of the firmware settings is just for flashing the board. gSender should read the settings that are already in the firmware and display them. I don’t know why it isn’t but I wouldn’t think that you need to flash it or change anything if it worked with CNCjs or UGS.

Do your settings show up when you enter $$ in the console?

I looked up that controller and they say its GRBL so I would think that it should work.

Hello Michael. Thanks for the welcome. I entered $$ and everything showed up, home buttons, Settings, and I was able to access EEPROM. I ran three small program cuts. I kept losing COM connection, but the program let me restart where I left off. I am not sure if this is an issue with gSender or my USB cord.

Wow! I was thinking that entering $$ would give more info to the devs, not that it would get everything working but I’m glad it did.

Yep. the only problem, it doesn’t save the settings. So every time I lose connection, I have to enter $$ .

@QbeeHulk Fred, entering $$ does not set or change anything. It simply lists all the eeprom settings. So, if the settings are being changed by some unknown process. entering $$ will not change them back to what they were before you lost the connection.

Hmm… that is strange behavior but I have a guess as to why. First off, is this the controller that you have? I will continue under the assumption that it is the controller you have.

It says that it is GRBL ‘based’ and that it is 32 bit. I could be wrong but I think that GRBL was designed specifically for the Arduino 8 bit platform. That said they are working to expand it to other platforms with GRBL-HAL.

Anyway after that techno-babble, I would suggest that you try gSender Edge which is where new features are tested before making it to gSender. It has support for GRBL-HAL and may work better with your controller. You can get the latest gSender Edge from here, expand the Assets at the bottom of a release and get the one for your Operating System.

1 Like

@_Michael I just looked at the link that you provided, Michael. I would bet that you have hit on the problem and, more importantly, on the solution.

Let me clarify about losing settings. When the COM connection drops, the homing icons disappear. Also, the EEPROM info can’t be accessed. It still was able to run the gcode for the job. As soon as the job was done milling, I entered $$ and the icons came back and the EEPROM info was restored.

The CNC ProV-5 controller has 32 and 64 bit downloads. The problem I was having with CNCjs was a COM port issue. That is when I found gSender. I still had a com port issue. More research and I find the ProV-5 put out an update for “No com port unavailable”. Now gSender works intermittently. I am going to see if CNCjs works and if its intermittent. I do like gSender better.

@QbeeHulk Understood, Fred. I’m quite willing to be proven wrong. It happens often. :grinning:

However, everything that I have read on grbl commands and all my experience shows that $$ does not change anything. Here is the text from the grbl library, for example:

"$$ - View Grbl settings

To view the settings, type $ and press enter after connecting to Grbl. Grbl should respond with a list of the current system settings, as shown in the example below. All of these settings are persistent and kept in EEPROM, so if you power down, these will be loaded back up the next time you power up your Arduino."

If, for some reason, your board works differently, I can’t argue.

That said, though, if the controller you are using is the one that @_Michael found, then I can see why you are having issues with gSender. gSender is flashing the eeprom for the Sienci Long Board controller. On the page that Michael linked, there is a firmware download. That is what you should be flashing your controller with - again with the proviso that it is the one that Michael linked to.

Grant is correct in that $$ only lists the current EEPROM settings. We use those to determine if the homing functionality should be displayed (it’s enabled in EEPROM) which is why it disappears when disconnected.

It looks like you’re not running vanilla GRBL (just from the mention of 32bit) so there might be some compatibility issues between gSender (which expects vanilla grbl/grblHAL) and your controller - this would be one of those quirks.