gSender 1.0.0 and 1.0.1 pause bug

Attached is one of the files that I tested.

I can run the file from beginning to end with no issues.

However, if I pause the execution, then resume, then pause again, I get an error 24 on line 31. The execution stops. I can’t get a screenshot of the error as it does not stay active long enough.

I can hit resume and execution does resume. If I hit pause again, I get any of these errors: error 1 on line 32, error 2 on line 39, or error 24 on line 39. (There may well be others. I stopped hitting pause at that point.) The thing is that the execution shows that it is well past any of those lines when the errors are reported.

After two or three of these errors, when I hit resume, execution resumes but at a very slow feedrate. The feedrate before the error was just under 4000. It drops to under 800 after the errors. If I increase the rate to 200% using the gui, it rises to about 1600, runs for a few seconds, then increases to well over 4000 with no input from me.

1-.25DC_topcarve.gcode (24.7 KB)

@gwilki - Grant, even though I didn’t push it as far as you did I am also getting the “Error 24” after hitting pause the second time. The console shows a truncated command just above the error text. I have paused more than once but I only get the “Error 24”. None of the other errors you got. (@chrismakesstuff)

@Heyward43 Tks, Heyward. I should have looked at the console and reported on what I saw. I’ll leave it for now, but will do that if the Sienci techs need the info.

1 Like

This is also happening in version 1.0.1.

I am attaching a gcode file. This is just an example. The bug occurs in all the files that I’ve tested.

I can run this file non-stop with no issues. However, if I run the file, hit pause, then resume, then hit pause again and resume again, it runs for a brief period, then stops with the error

“error 24 on line 549 Invalid gcode ID:24”

Hitting resume again continues execution of the gcode. Pausing and resuming again causes the same error to pop up on line 1231.

2-60°LV v-bit.gcode (2.8 MB)


I am experiencing the same thing, although I don’t know what causes it, but if I ever hit pause and resume, the machine will do a random pause again shortly after I have resumed the job. Happens consistently.

1 Like

Is it the same behavior if you Pause and Resume(Play) via the Longboard PushButtons?

@webbit_NJ No, I just tested it using the buttons on the controller and the file runs to the end, without errors.

1 Like

Running 0.7.4 under Windows 10.

Tool path is running and I hit pause on my numeric keypad. The job pauses. Within a few minutes, I hit send and the Mill starts moving. Within a few seconds, it stops. Hitting send again starts it moving and it finishes the cut. However, gSender seems to have the project still open, as the resume and stop gui buttons are still active, and the load or jog buttons are not. I need to click to stop the project before I can jog or do anything else.

I’m attaching one of the gcode files where this happened. It has happened on others, too.

3-outer ring.gcode (91.8 KB)

To update this old thread, I believe we implemented some new handling to address this pausing bug - is anyone that reported it still seeing it happen in 1.0.6?

@chrismakesstuff I can confirm that, for me at least, the issue is resolved. I don’t know if that is a function of 1.0.6 or other changes that I have made.

I will close this as no one has followed up. If it is still an issue for others, they can open a new thread.