gSender 6.6 Beta Windows - problems with usb recognition

I have been having problems with my long mill if I boot the PC with the emergency enabled and turning it on after I log into windows.

I have my motors engaged all the time, so I have been using the e-stop as a kind of off button

With a power button at Powers the PC and the Long Mill. Before I put everything away at night I usually hit the e-stop shut down Windows and then turn off the power bar.

I find that alot of the time, I boot up, launch gSender and remember I forgot to turn the e-stop back on. Once I turn the e stop button so I can run things I find that gsender isn’t finding the USB device

I know with ugs there’s a refresh button for it to go and find the USB devices is there one for gSender?

No amount of closing and restarting gsender finds it, however if I unplug the USB and plug it back in gsender finds it

Sounds to me like it’s a windows issue. Windows 10 has a built-in tool for detecting errors and conflicts and correcting them. Running the Troubleshoot tool will also scan your device for the required device drivers and will download them if they’re available online.

To access the Troubleshoot tool, open Settings from the Start menu or Action Center, then select Updates & Security > Troubleshoot. Once on the Troubleshoot screen, scroll down the list of options and select Hardware and Devices. Select Run the troubleshooter to begin the system scan and repair process.

Not saying your wrong I need to keep testing.

But I will say,. UGS has not had the same issue

But UGS has a re-scan devices feature

1 Like

To keep the USB ports on, click Change advanced power settings


In the separate window that appears, you’ll want to Expand the USB Settings, then USB selective suspend setting, and finally change this drop-down to “Disabled“. Click to Apply these new settings.

Tks

But already disabled

My PC in the garage is never turned on

In my case I will turn my PC on with the e-stop enabled

So your scenario in my scenario are quite different

Because the weight of my spindle I’m pretty much forced to leave my motors powered on all the time

Otherwise I have Z drift.

So my order is almost always

  • power on the PC
  • Launch gSender
  • realize that the e-stop is on
  • at this point I’m either forced to unplug the longmill

On the days where I use the ugs, I go through the same process but I never have to unplug the Long Mill or reboot the PC

I don’t know if you experiences because you don’t have the e stop
But from time to time g center is open the USB shows connected , but the state status shows disconnected

My next test I think is going to be to reproduce this and instead of unplugging the USB I’m going to try launching its, and see if I can reset the status of the USB without unplugging it

1 Like

@Menglor I can try to reproduce this when I’m back in the office on Monday. What I’m curious about is that the e-stop is only powering the motors, the processing portion of the LM controller is actually powered by the PC it’s hooked up to, so at first glance it feels like the on/off of the e-stop should have no effect on your LM connecting/disconnecting from gSender.

With your list of steps it should be straightforward to attempt to reproduce on my end though. :+1:

1 Like

So it’s all rather frustrating

I tested this last week and I was reproducing it three times

Today I tried it five times and every single time it works just fine

Take the win and enjoy :+1:

Sadly, its not a win when your trying to reproduce a bug to prevent others from experiencing it.