gSender odd hangs/fails

Hi Folks… I just switch to gSender from jsCNC nd at the same time installed limit switches. I’ve enabled homing, soft & hard limits. and while I really like gSender so far I have had some issues. Some background, the Longmill is my second CNC and I’ve been using a CNC for about 3 years although my use goes in spurts I’m running this on Windows 10 and I’m running longboard ver 1.3 and flashed to the latest firmware using gSender… I’m running gSender 1.0.2…

So my issues are I am getting random stops/hangs, sometimes I get an invalid feed rate at line x but if I rerun the gcode it will process that line no issue and sometimes it just hangs/stops with no indication in the console other than “reset to continue” as to why. These are all short (less than 60 min) carves but they are 3d shapes.

I’ve included a couple of screen shots but not sure they are of much help…

Any ideas… I’ve turned off hard and soft limits and that MAY have resolved the issue but I have not done enough carves to be sure but regardless I would like to have those enabled.

Help appreciated…


Kerry, I ended up disabling hard and soft limits, too, after I got a false limit reached error during a carve. I haven’t had any issues since, but I never saw the invalid feed rate error.
I have an older Longboard so added the provided caps. They don’t seem to be providing enough noise filtering.

1 Like

I really don’t see what hard & soft limits should have to do with this but it does seem to have worked. I would however like to have hem enabled so it would be nice to sort this out…

In case it is relevant: I was using my laser this weekend and found that things went bad with a high feed rate F1800, whereas F1200 worked fine

1 Like

We’ve tried a couple approaches to fixing these strange hangs recently and it’s hard to tell if we’ve finally caught them or not. Have any of you guys still been seeing this sort of behaviour? Is there a pattern that you notice to the behaviour?

@paullarson @saskia @klwstrings

@chrismakesstuff , I’ve had limits turned off since shortly after I added the limit/homing switches. A couple months ago I added pull-ups to the caps (I have an older controller) hoping that would help, but it didn’t so I turned limits back off again. I wasn’t doing anything special for any of the errors.


So the hangups seem to be limit switch related then? No hangups if limit switches disabled?

It’s odd that the cap + pull-up combo didn’t work. What value resistor did you use?

@chrismakesstuff , I used 20K because it was in parallel with the internal resistors and I didn’t want to lower the combined resistance too much. I do have some 10K. I could try those, if you like.

1 Like

@chrismakesstuff , I found that all I had to do to recreated “Alarm 1” was to set the speed to rapid and run back and forth on the X axis. In less that 10 trip back and forth the machine would get a hard limit error. So, I changed the 20K resistors to 10K and tried again. It still failed. Then I tried unplugging the limit switches from the controller (at the controller). I ended up with all of them unplugged and it still failed. Not quite what I was expecting. I was thinking that noise was riding in on one or more of the limit switch cables. I guess not. This would seem to indicate that if it is a noise problem, the noise is from another source and is coupling on the controller board.

1 Like

Hmmm, in that case I’m not exactly sure what might be going on here. I’m not even sure if it’s a gSender issue or some other issue with noise on the machine itself.

is it noise or a bug in the Arduino firmware?

If it’s software/firmware it’s probably GRBL. I don’t think gSender would be involved.

1 Like