Laser offset settings not retained

A Long Mill user has reported, and I have confirmed that the laser offset settings are not saved when exiting gSender or even when moving from one menu item to another in the same gSender session.

gSender puts up a pop-up saying that the settings have been saved, but they are not.

1 Like

I hope someone is going to look into this…?

Noted, will look into this for the next build

2 Likes

This should be fixed in the next release - we’ll follow up after it’s been published.

Kevin

2 Likes

@chapklc Kari, just FYI.

1 Like

@gwilki @chapklc has this issue been fixed now for you in the 1.0.6 release?

@chrismakesstuff I’ll look tomorrow and report back, Chris. Ditto on the other two issues you have asked about today.

1 Like

@chrismakesstuff @chapklc Chris. I can confirm that this issue is not fixed in 1.0.6.

Here is my test process:

  1. Open gS and went to settings.

  2. Selected spindle/laser and entered an arbitrary value in both X and Y offset.

  3. gS returned that it has updated the settings.

  4. I moved the toggle to laser

  5. Back in the home screen, I turned on laser mode.

  6. I disconnected from the com port and closed gS.

  7. I re-opened gS and re-connected to the Mill.

8 I went to settings, spindle/laser and the offset settings were changed. I had entered 25mm in each of X and Y. On re-start, gS had set them to 1 and 0.

9 I tried the same process 3 times, with the same result each time.

Back to you. :grinning:

1 Like

Verified and working on a fix. Thanks for providing the steps to replicate Grant :rocket: :rocket: :rocket: