Newbie blues - Travel exceeded

Hello CNCers,

I was doing OK with a few test carves, then decided to flatten my waste board. I generated the Gcode and was trying to start the process, but I have somehow pinned the Longmill into the corner. Z jog still works fine, but X and Y jog can now only be moved to a small percentage of the bed. Trying to move back in the Y axis or to the right in the X axis result in an “error 15 (Travel exceeded)”.

Also, when I click “Home”, the router moves up the Z axis, tops out, and starts clicking. I have to hit the Big Red Button to stop it :((

This happens after a reboot of both the computer and control board, and with both gSender and UGS.

Any ideas what I’ve done?


-Mike M

Hi @mike99mac ,
Aside from flattening your Wasteboard, do you have this issue?
Are you using The Sienci Limit Switches?
When triggered, they show contact via a RED Led
Have you tried testing each Limit Switch contacts (via the Console Window)?

See halfway in:

Are you sure your Z limit Switch is wired to the correct port?

The “error 15 Travel Exceeded” comes from enabling Soft Limits.
Have you tried disabling Soft Limits?

@webbit_NJ thanks for the quick reply.
No, I’m not using the limit switches. One web page said something like “not recommended for newbies”. I’m thinking I should buy and install them.
I will look into soft limits. This sounds hopeful because the travel is nowhere near the hardware limits.

-Mike M

Hello again…
If you have no limit switches, then you should not use (or be able to) HOME…
Make sure:
Soft limits are not enabled
Hard limits are not enabled
Homing cycle is not enabled
Let us know if this works…

I used the firmware tool to turn off hard and soft limits in variables 20 and 21. My router is no longer in the penalty box. :laughing:

Also, I will not use the Home button unless I buy and install the limit switches.

Might there be a setting in gsender to specify no limit switches and then the Home button would be grayed out? Just a thought.

Thanks to all who helped.

-Mike M

More newbie blues :frowning:

I went to and generated the gcode for waste board surfacing using 762mm x 762mm x and y (and copied all other settings). I copied the gcode to my clipboard and saved it to a file with a .nc suffix. Here are the first few lines:

( File created using Intuwiz Software Service )
( )
( More information: )
( File created:  2021-11-24  13:50:39  UTC )

G01 Z-1 F500
G01 X740 Y0 F2000
G01 X740 Y9.9
G01 X0 Y9.9
G01 X0 Y19.8
G01 X740 Y19.8
G01 X740 Y29.7

I then jogged the router to what I believe are the machine hardware coordinates (black smaller numbers below the blue larger numbers) so they were all 0.00. I clicked ‘Zero all’ and now all 6 numbers are 0.00. I jogged the machine up in the z axis a couple of times.

I loaded the gcode file, turned on the router and clicked ‘Run’. The router plunged a small amount, started moving right on the x axis and then stopped very soon after, but of course the router was still spinning so it dug a very slight hole. Here’s a picture:

Any ideas on why this happened?

-Mike M

In which direction travels the router when you are manually jogging in x+ direction? So when you press the x+ button in gsender?

Pressing x+ moves it to the right.

(and pressing y+ moves it to the back)

-Mike M

I tested this in GSender:
Go into Firmware and disable “Homing cycle”
The homing Button (And requirements) should dissapear.

Hi again…
I also used INTUWIZ in the past, now GSender has it own Surfacing Path Generator…

@webbit_NJ - Thanks for your quick appends to this issue.

I have solved the problem, and it is somewhat embarrasing. The router’s power cord was getting stuck on the corner of the ?gantry?. All I had to do was to add a ‘tie wrap’ into a screw hole to keep the power cord from getting caught. You can see it in the upper right of the attached picture.

The waste board flattening job has run, and while I thought we had built an extremely flat base, it was not as flat as I had hoped. Here’s a picture:

Boards 2 & 3 from the left tail down a few thousandths towards the back, but I guess it could be worse.

Again, thanks for everyone’s help. Moving forward … now it’s time for dust collection …

-Mike M