Power issue with controller

Longmill 30 was running fine yesterday, 4 cuts in corian and one in pine without issues. Turned on the controller this morning and the red lights flashed on and off but no power. Tried numerous times but the same result. Unplugged and re plugged the connections with the same results. Any ideas on what I should do next?


@Phil - It is possibly the switch. There have been issues with the power switch in the past. I don’t know which version of the controller you have but if you search for power switch on this forum you will find several postings. Tells you how to check the switch. Also a work around if you’re up to soldering some power connectors. If you don’t feel comfortable soldering I would contact Sienci. Keep us posted please.


I had that very issue Phil. And as Hayward suggested, it was my On/Off power switch. Earlier controllers had that problem. I soldered the two on/off terminals and it fixed the problem. However, I now have to power on and off with a power bar toggle switch. I believe Sienci should have addressed this issue when it became apparent as it seemed prolific in earlier models. But the work around Hayward suggests works.

1 Like