Probe function works in metric but not imperial

Hi, I’m fairly new to CNC and very new to Gsender. I have a MillRight Carve King 2 and purchased their touch probe with it. I run it off of a Raspberry Pi. 4000 all in one keyboard/Pi. I have plenty of strange things happen and will try to resolve them one at a time.

My most recent issue is when using the touch probe with my machine set to imperial measurements it will not complete the Y axis portion whether I run the XYZ or the Y by itself without giving me a #2 error. That being said I found out on my last project that if I set my settings to metric, I can use the probe feature without issue.

I’m wondering if this is something that I’m doing wrong or if it’s an actual code issue. I had no issues with the probe function when using USG, just many other issues.

Thanks. Len

1 Like


Are you getting alarm 2 or error 2?

Could you share the contents of your console when this happens?


Yes I get Error#2. My shed is not heated so I haven’t been spending much time out there, but when I do I’ll share what I find.

Sorry, I think it is Alarm#2, something about an unexpected movement before 38.2 I believe.

I got a chance to run my machine for a simple facing job last night . I was having all sorts of trouble so I flashed GRBL and uploaded 1.05 onto my Raspberry Pi and the probe function worked fine. I was having a problem with a constant Y+ offset and it seemed to go away for now also. I plan on getting some more time today in the shop and will post any updates. Thanks.

I got a little time to run the machine again. This time I ran the surface function on both sides of a piece of HDPE and then ran a program that I had trouble with the offset. It’s a simple program that would show the offset even at a glance and it seems to be gone.
I’ll try some other things later to verify my results but that is all that I had time for today.