Running UGSPlatform on OSX

I am running the latest build of OSX (10.15.7) and have installed the latest version of Java 8 (build 1.8.0_261-b12) but when I run UGSPlatform the terminal outputs ‘Unable to find any JVMs matching version “1.8.0+”’

The app begins to load then a modal pops up with the heading “Nightly builds” then it crashes.

Haven’t been able to try out my Longmill yet as I can’t overcome this hurdle

Any suggestions are appreciated!

@ryanprice What version of UGS are you trying to run, Ryan. The October 2020 platform comes with its own java.

@gwilki I’m using Aug 2019 build recommended in the longmill setup instructions.

Looks like OSX 10.15+ has an issue with Java JDK 15 (the current version) and needs to use v12.

Got the app to load by using these instructions: and setting the path to v12 via the ugsplatform.config jdkhome override.

@ryanprice I realize that the old longmill setup instructions refer to the august 2019 build. However, many here had problems with that, and there have been several updates. The most recent is October 2020. I have been using the August 2020 build with no issues at all, following a period of freezes with the august 2019 build. YMMV of course.

This is good to know! I will definitely try a more recent version once I figure out how to get the machine up and running :wink:

So I tried using the Aug2019 stable build and it can’t detect my longmill. I then downloaded the nightly builds Aug2020 and the classic version can’t find my longmill either. The Platform version manages to find the longmill, but when I try to jog the stepper on any axis there is no movement. I can hear the respective motors humming, but nothing moves. I can’t seem to find any info on next steps

@ryanprice Check your feed rate in the Jog Controller window. I think UGS defaults to like 1. Make it 1,000 then try 1 in the Z and XY step settings (mm settings).

Sorry - I updated the numbers above. I actually have 10,000 set on my feed rate in UGS - the LM won’t move that fast.

Yes, that was it! Thanks, Steven. The feed defaulted to 100 and must’ve been too small to see any movement

1 Like

Great! You’re welcome.