Sienci Laser issue

Anyone trying to get their laser to work yet? I got mine all hooked up late Thursday night and tried to engrave something. I am using LightBurn. When I set laser up it will burn the wood depending on where the power is set but when I set up LightBurn the way the video describes and run g-code, the laser seems to stay in very low power and at 25.4 mm/S does not leave any make on the wood. Any thoughts?

1 Like

@Vette95 Welcome back, Mike.

There are two settings that you need to make that may resolve your problem.

In LB console, you need to enter $30=1000 and $32=1. These set the max speed (which is power in LB) to 1000 and turns on the laser mode. Then in LB, you need to set S max to 1000 - to match the $30 that you entered. The $30 number can really be almost anything. The key is that it must be the same in grbl as it is in LB. 1000 is nice because when you are setting the power percentage in LB, you are dealing with a nice even number.

When you go back to using your router, in either LB or gSender, set $30=3000 and $32=0. this puts things back to route defaults.

1 Like

isn’t there a setting in gsender that sets the app to switch from CNC (router) to Laser. I would assume it would make those changes when you switch.


@digiital Welcome back, David.

That’s an excellent question. I really wish that I had an excellent answer. All I can tell you right now is that I know for sure that moving the laser slider in gSender does not change either $30 or $31. I will take this up with the Sienci techs after the holidays.

With respect to @Vette95 /MIke’s question, he is using LB to talk to the Mill, if I understood him correctly. So gSender does not come into play when changing these settings.

I will try those changes, but just to clarify, I using LightBurn to generate the g-code but gSender to run the code on the CNC. Per the video, I set the max S to 255 in lightburn. I did enable the laser mode in gSender. As I stated when setting up laser using gSender the power setting seem to work great and it will burn the wood but not when g-code is run. Could be the settings as u mentioned. Christmas Eve, I will likely sleep in doghouse if play with it tonight :slight_smile:

@Vette95 I apologize, Mike. I should have watched the video before mouthing off. Further, I didn’t realize that you created the gcode in LB, but didn’t run it in LB. LIke you, if I’m not a polite host tonight, I’ll be sleeping in the car.

I will watch the video and may be able to offer up some better advice.

Merry Christmas, and sorry again.

Ha, no apology necessary, I appreciate any help I can get. Excited to make it work and don’t want to wait until the new year when the office is open again. Enjoy Christmas Eve and day and then any suggestions would be appreciated. Thanks again

P.S. I will likely play with those setting tomorrow afternoon to c what I can come up with. Guessing it is a mismatch between gSender and LightBurn

The key is whatever you set for $30 in the LM controller EEPROM you have to set in Lightburn. I set 1000 in both places thinking it gave me more resolution and also was easier to work with in my mind in percentages. I have since learned that the PWM used to control the laser intensity is only an 8 bit register so only 256 settings are available so using 255 in both places does give you the maximum resolution. So, either works as long as they match.

@Vette95 Well, Mike I can now say, with some degree of embarrassment, that I have watched the Sienci laser video. While I don’t pretend to understand how it does it, turning on the laser slider in gSender seems to accomplish the same thing as using $32=1 to turn on laser/pwm mode in grbl. I know for sure that it does not actually enter $32=1 because I confirmed that, even with that slider turned on, grbl still shows $32=0. That said, it is of no importance that I understand it.

As I said previously and as Paul has confirmed, the key to the power issue is that LB and grbl are using the same number. Sienci recommends 255 for the reasons that Paul set out. I learned to use 1000 and it works for me, so I will stick with it.

I’ve never done a project where I created the gcode in LB and ran it in gSender or, in UGS before I started using gSender, so my experience may well not be completely relevant to your process. I do think, though, that the settings that Paul and I have set out will get you started.

Have fun.

On gSender Console, I set $30=255 and $32=1 as you guys suggested. Everything now works great. I agree that the slider in settings to turn on laser mode ought to change these parameters in gSender and than change back when exiting laser mode but this will work for now.

Thanks again and Merry Christmas

1 Like