Skewed it up - Y travel

New LongMill 30x30 user. Setup and first few test projects went pretty well. But have noticed that the travel on the Y axis is not consistent. If I bottom out/zero the gantry to the “top” (where the 2 stepper motors are) and then jog the machine down, it is travelling slightly less on the right side; out about 2mm mid way and close to 4 moving all the way down to the bottom/front of the machine.

Pic for reference. Any thoughts greatly appreciated!

@jason.shoes Welcome to the group, Jason.

This has come up before and I’ll try to remember all the advice provided. I guess the first thing to do is to check that, when you run the x gantry to the back (or front) of the y gantries, is the x gantry square to the y gantries? If it is not, you need to move one of the Y gantries backwards or forwards until it is.

If the X gantry is square to the Y gantries when it is at one of the endstops, switch the wires on the Y motors and see if the problem switches with them. Meaning, in your picture, does the 298 move to the left side and the 300 to right right. If it does, check the motor wiring to ensure it is firmly plugged in. Check the dipswitches on the controller to make sure that they are correct. Change each switch, then move it back to ensure that they are all firmly where they should be.

If the problem does not move to the other side when you switch the wires, then you need to check a couple of things on your Y axes:

  1. check the delrin wheels to ensure that one side is not too tight

  2. check the anti-backlash nuts for the same issue

  3. check the coupler between the motor and the lead screw to make sure that there is no slippage

That’s all that I can remember for now. Others may add to this list. Let us know how you make out.

4 Likes

Great, thanks for that. I’ll double check for square and try the plug swap for starters.

Ok, so here’s what I’ve tried:

  • Swapped Y motor plugs, same results
  • Reset all dipswitches, all wiring secure
  • Checked all wheels, anti-backlash and couplers

After all that, I did the 3-4-5 method with these results. Comes up a bit short on the “5” side. That would mean the Y (b) side needs to move down a tad?

Yes. It’s not out by much. I would try to make the triangle bigger is you can. I don’t know how you took your measurements, but here is an excellent video, fyi.

Ya that’s the vid I watched for the square up. :+1:
I think I could squeeze a 800 x 600 triangle for a more accurate test.

1 Like

Hey Jason,

It could of course be due to any of the suggested reasons above, however, i had the same issue with mine and the actual problem was the pitch of the lead screws. If the tests mentioned do not bring fruit, try to switch the lead screws between the sides and if the problem is now mirrored onto the other side you have your answer right there.
All i can say is that the guys at sienci were very helpful although it took quite some convincing that that was the issue. I tried a few lead screws until i found a perfect match and with that i could later calibrate the travel distance with siencis guide on micro stepping. I hope this could help.

Ahh, thanks for that, something else I can test out!

I still need to mod my table so I can make micro adjustments on the y axis, I’ll probably try that first and see where I’m at.

1 Like