The next big release for gSender is here! (1.2.2)

Yes definitely, it’s pretty bare-bones as-is but the long-term plans are much greater for job tracking and maintenance reminders. Thanks for the feedback Doug :+1:

2 Likes

Greetings – as reported in the 1.2.5 EDGE release, I’ve had no success since 1.1.7. I can load gSender, but file loads often fail – or all responses fail within about 30 seconds.

I can connect to my OpenBuilds Controller, even though it doesn’t show up as an available controller. I can home in all axes, but pretty much that is it.

Running a pretty vanilla Debian Bullseye system. Diagnostics attached, and happy to help test any way that I can.

John
diagnostics_6-15-2023_21-54-06.pdf (10.7 KB)

1 Like

This is Awesome! Congrats to thee entire team!

1 Like

Hey folks - 1.2.1 is released with some quick fixes for file loading, controller jogging, and more.

  • Fix for files not loading for some users
  • Toolchange strategy missing units added
  • Controller functionality issues addressed
  • Calibration tools calculate correct values based on input
  • Surfacing unit conversion on RPM removed
  • Laser unit renamed to Power from RPM
  • Color theme loading no longer loads non-existant file

We should have fixes for other issues cropping up in the next few weeks - but for now enjoy being able to load files again.

@all

1 Like

A post was split to a new topic: Tool change option problem

A post was split to a new topic: File loading issues in 1.2.1

A post was split to a new topic: Bitsetter in 1.2.1

Can’t wait to try out the new version. I’ve used some of the features in Edge already.

I’m a developer and have some things I’d like to contribute to the project. Are there any published design docs that I could use to familiarize myself with the codebase? Is there anything special I need to know for development, or is it just a standard Electron project with the typical scripts?

Great work!

1 Like

I think this has been discussed a few times. It would be nice to be able to output at least filename and start/stop date/time. Being able to see stats in the new version shows they are getting there in collecting the data. It looks like just file output is the next step. Not a simple task given you have to support multiple OS versions but I would guess a CSV file is what we can expect to see in the future.

Good day. I there any update on when gSender will enable the autozero touch plate to be used on other corners? Thanks

Nick

1 Like

Exciting news that these features have been pulled in - any early ideas on what to develop next?

I can’t answer your question but I can welcome you to the group Michael. So welcome to the group! I hope your question gets answered because we all want to know :slight_smile:

Hey folks, 1.2.2 has been released which should address some of the more common pain points we’ve seen reported.

  • Fix for overrides leading to gcode errors
  • Override button now correctly sends minor adjustment with slider for major
  • Override value correctly updates with keybind usage
  • Using override keybind should now display the override panel
  • Multiple toolchanges in a single file now display the correct tool number in the Wizard
  • Controller binds should work with toolchange wizard active
  • Spindle RPM no longer incorrectly converting units
  • Spindle slider now reflects EEPROM values for min and max
  • Jog speed properly converts through preferred unit changes
  • Larger margin on shortcut printout
  • M0 in feeder macros now displays M0 pause dialog
  • Added missing outline keybind
  • Unlock keybind should work in more situations where a soft reset was required

As always, the latest version can be found on Github:

2 Likes

Kevin, I will load the new version and try it.

Thanks for the update!

1.2.2 seems ok. M0 throws a dialog and allows tool changes, which fits nicely with output from Carbide Create. But M05 and M06 just pause the machine with no indication of why, which could not be differentiated from some abnormal cause. And M0 is ignored in the first few lines of a file. Mac user OSX10.13 / 2011 27" iMac

Playing around with 1.2.2. Apparently M0 does not take any parameters? If I throw a S# or P# after the M0 I get an error message so this clearly just to stop execution until the Resume Button (in the message box or main window) is clicked. I believe that some implementations of M0 allow including a string as a parameter that populates a message box. Clearly not the case here but would be nice if we could throw a string at the M0 command and have it populate the message box … or not.

I apologize for my ignorance here, but which 1.22 file to I download for a windows 11 64 bit system? there are several options available it seems when I go to github.

@IBCRAZY8220 You want the one the ends in x64.exe :smile: gSender-Setup-1.2.2.exe would also work, it’s the same file, different name, I checked the checksum’s.

Hello,
i am missing the possibility to run self made gcode before and after a M6 tool change command as it was able in 1.1.7.
Because gSender is not processing the “PRB:” message from a probing command i have to use the special probing command only included in FluidNC with the P-parameter (Probe | Wiki.js) to get the exact trigger position of the tool sensor / sensor plate. Because of that i run my self made tool change code.
So it would be very helpfull if you could add additional the originally functionality of running your own code before and after a M6 command.

Thanks for your help, I appreciate it. I’m in the process of swapping my router for a spindle and I’m trying to get all the bugs worked out of gsender first.

1 Like