Touch Plate/gsender- Cannot confirm circuit/Green Light

I’ve been researching and watching videos for 3 days and tried everything that has been mentioned about the touch plate troubleshooting. The only video I see that shows gsender and the touch plate is the one by Kelly that a few has said not to follow. Did the z axis test raising router up touching magnet to plate. Checked all settings, connections, took apart banana clip and magnet to make sure the wire wasn’t covered in coating. Touch red wire directly to magnet, plate to bit. The red is matched with probe and black with ground at controller. Used a volt meter to see if their was power coming out of board and continuity at other end of wires with them exposed. I even reinstalled gsender. My spouse and I worked on hot tub control boards so I am familiar circuits, dip switches, continuity and the such but not CNC machines. What am I missing? At this point we are thinking its the programing of the controller for touch plate. Please help.

Thanks in advance,

@Stylecdesigns , From everything you’ve written, you’ve already tried most everything. You do have the touch probe cable plugged into the correct socket? The one labeled Probe and GND? I’m sure you do, but that would be the simplest fix. So, when you you use GSender, initiate a probe and touch the probe block to the bit you can’t get the virtual green light?

It’s actually a very simple circuit and function. When the bit and touch block touch each other it closes the circuit and connects the Probe pin to the GND pin. If you take your voltmeter and set it up for continuity/Ohms/resistance you can measure at the cable end (after unplugging) to make sure there is close to 0 ohms when you touch the probe block to the bit, assuming the magnet is attached to the router chuck. If you do, then I would guess the problem is in the LM controller. I looked in the EEPROM settings and a didn’t see anything that was related to the touch probe for your to check, but I could be wrong. The only other thing I can think of would be to reload the LM controller firmware, which I think you can do with GSender. I’ve never done it personally, but I’ve heard it can be done.

1 Like

Sorry I just realized the email bounced back and I had to respond here. We checked the continuity/ohms how you suggested and we have confirmed there is definitely a circuit but the light stayed red. Also, initiated probing through gsender touch plate plugged in, touching the block to the bit starting at a reasonable distance and bit to the block didn’t work no green light either time. I did magnet to block with red clip plugged in plate and controller plugged in few more times like Chris does in one of the videos. Yes, the red is plugged into probe and ground is in black, and plugged into correct spot. I don’t think the touch plate was programmed to the controller which I assume we are talking the GRBL firmware and reloading that. I don’t know the first thing about it or how to get into that to do it. However, I went through the Firmware setting located at the top of gsender and found something that says “Invert Probe Pin-Inverts the probe input pin signal”. I enabled it just to see what would happen and the light was green even when nothing was connected and stayed green. I was able to actually start a probe but it just kept drilling down and had to E-stop. Then a warning code was thrown. I disabled it after that craziness . So what do I do, Can you find out more info about reinstalling/reloading the firmware to get this touch plate to correspond?
On another note. I’ve been using the 1/8 flat endmill with all the tests. I ran the longmill practice project the other night for the 1st time, switched to a 1/4 endmill zeroing best I could. Came out beautifully. I ran all those touch plate tests again with the 1/4 just it was the bit.
Just in case…Can you check these photos of the settings and the back of the controller to make sure everything is in place? I did restore default settings on gsender under general settings in case something got switched on accident.

Thank you for your help on this, hopefully we can get this resolved.

Remove the connections you have and just short the Probe pin to Ground. Use any wire or even a paperclip. Does it still not respond?
This is not a firmware issue.

@Stylecdesigns @NeilFerreri
Neil makes a good suggestion, but since you already checked out the probe block and wiring with a meter I doubt it will make a difference.

Like I mentioned before, you may have a bad LM controller. If that’s the case you can contact the folks at Scienci and they should get you fixed up.

The behavior you experienced when inverting the Probe pin is what I would expect although I’m a bit surprised it actually moved the probe down when it thought contact was already made.

Neil, I mentioned reloading firmware on the LM as a hail mary pass, just in case something got messed up. I think Gsender makes it pretty simple, but I’ve never done it myself, and it’s easier than swapping controllers.


Yes, thank you Paul! I agree. What does that Inverting Probe Pin enabling actually mean? It makes the machine think the pin is in and there is a connection? That just reminded me…I clicked on the Flash GRBL button, I got and error but don’t remember what it said. Ill have to check. I just found the number to call . Thank you for the help!

It means that the controller logic is reversed. By default, and by design of the LongBoard, the probe pin is held HIGH at +5V. A successful probe (connection between the endmill and probe plate or pressing of a switch) will result in the probe pin being connected to ground and being pulled LOW. Some controllers or probes may be designed such that you’d have the pin held LOW until a successful probe pulls it HIGH.
You don’t want to invert the probe pin.

1 Like

@Stylecdesigns Brittany: Did you resolve your problem?

Tech support resolved Brittany’s issue :slight_smile: