UGS won't run more than 2 files before it acts up

I was making practice cuts this weekend and ran into an odd problem. The first time I run a file in ups it runs just fine, sometimes 2 jobs just fine. After that it will start move to the position for the first cut and just sits there. If I disconnect and reload sometimes it will work a couple of times when I tried to return to zero it went way of target and dropped much lower than the setting. Seems to act the same in the 32 bit version and 64 bit version. I don’t think it is the files as I have been able to run them successfully. I am using the nightly build version go UGS. I plan on downloading an older version but though i would post here first for any advice.
I don’t think it is EMI from the motor as it is pretty consistent but have ordered a shielded USB cable with filters at both ends.

Scroll down and download the older version. The nightly versions have not had enough vetting to be 100% bug free. The older ones have.

The move for the first cut then stopping sounds like the tool change code that needs to be removed from the gcode. Mine was doing the same thing and that solved it.

Thanks good to know but I don’t think it is the case for mine. This was 2 separate files with just one tool path in each and both files run just fine if I just run one job. Also the it moves to the correct path and brings the z axis right down to the depth for the first cut then doesn’t continue. However I did look at the code and will bracket out the M5 line and see if it does fix it. I am going to try and older version of UGS also but will run separate trials and post back the results.

Would you suggest an older version of 2.0 or go right back to 1.0x?

Scroll down the page where you downloaded that one and you will see another section titled older stable builds. Download one of those.

I ended having up downloading an older version and removing the tool change code and it seems to work better. I did 4 small files in a row, by the 4th file I had to disconnect the controller in USG and reconnect before the file would run. I only seem to need to remove the tool change code if I run consecutive files, that seems odd to me but as long as it works I’m happy.