Why does feed rate increase

Hello all this has happened a few times. When I change bits, the feed rate increases considerably more than that set in the CAD program. I set xyz to zero after homing it. To me it looks like it’s trying to catch up. For example, the feed rate is set to 40, but in the gender, it jumps to 1400-1600. Selecting the minus button in gsender has no effect. How do I overcome this?
Thanks

1 Like

@bubalarry What application is the feed rate set to 40 in? What parameters are they - in/min, in/sec, mm/min, etc?

Generally, if the minus button in gS does nothing, it’s because the rate in the code it has been sent is over the max feed rate. If reducing it still leaves the feed rate over the max, nothing will happen.

1 Like

Just a thought but are you sure that gSender and your CAD program are using the same units, I know there is a setting in the firmware to report in inches if you use inches, otherwise I think the default is mm/min for grbl. I believe that all gSender does is parse the status report from grbl and display that. As a side note you can see a status report if you send a ? to grbl in the console.

1 Like

Can you share your gcode?

1 Like