XAxis sometimes goes wrong way


My machine has been running fine for a while and today I decided to install the dust boot. However since installing the boot the x axis is acting up and sometimes going the wrong way. Happening when code is running and when using ugs to jog the machine.

I have checked that all the cables are seated correctly after installing the dust boot and they are all snug. I can’t figure out what is happening. Any help would be appreciated.

As well before I noticed this I started a surfacing gcode and it started to stwp up before it should and the the next line would go as expected but it would randomly move like the step count is off now.

@Kyfe When you jog it manually, using the buttons in UGS, does the X axis move in the correct direction?

When you say that it is going the wrong way, do you mean that you are running a project and the Mill moves opposite to what you expected? If so, does the project look OK when it is finished?

I should have been more clear in my haste to post.

Using ugs when jogging on x it will move intended direction then switch and go opposite direction. Or it will stutter at first and go wrong way a few cm before going intended direction.

For a program running the x axis movements are a bit random. I will grab a photo of what it did while I was surfacing and post in a moment.

And prior to adding the dust boot today it was running fine.

@Kyfe That’s just weird. (Sorry for the technical talk.)

If you remove the dust shoe, does it still act up?

I will have to wait till later this week to test removing the shoe to see if it continues to act odd. My patience today is thin at this point with the machine. It threw off all my plans.

@Kyfe I can understand your frustration. I’ve been there, too.

Another question. When it acts up, do you have a vacuum or dust collector connected to the shoe and running? If so, try something without the DC running. I had issues when I first went from a shop vac to my DC. I had to ground all the piping and hoses before things straightened out.

Sorry I have not been able to respond till recently. Lost access to my workshop while covid was happening. I recently went back and tried to take the shoe off, also no vacuum running, and with it running. Still same problem.
I recorded some videos to show how it is behaving.

longer video - trying to show what happens when it hits the end and reverses order - https://photos.app.goo.gl/MDibsFiwGjrM6cCb8

This video shows how hitting the same button can make it move in random directions - https://photos.app.goo.gl/94qPqE24irh3HuRc7

I am very confused - I can’t figure out why it would stop working properly. I also am attaching a link to my ugs settings to ensure it is not something simple to fix by chaning a setting - https://drive.google.com/file/d/1RXXbY0QmhrfRfQZanS18ucjg6LrlsPLj/view?usp=sharing

@Kyfe I can’t see in your videos what key you are holding down. Since you are using the keyboard, you should be looking at the keyboard mapping in UGS to determine just what signals your key presses are sending.
If you use a mouse to click on the UGS jog buttons, what happens?
I cannot open your UGS settings file, so I can’t comment on those settings.
I’ve never encountered what you are seeing, but, then, I’ve never used the keyboard to run UGS either. I think it may come down to how you have mapped your keyboard in UGS.

Hi grant

I only used keyboard for the video as it was easier to record and click. The keyboard mapping is the same as pressing the mouse. The keyboard is mapped to left and right for x and up down to y. I was pressing the left arrow. It really is baffling. I will try to get the settings into a basic txt document. Thanks for trying grant.

I can see in the video and from the surfacing that as soon as the motor is encountering too much force it’s changing direction. This isn’t normally possible due to the pattern of signals that are sent to the motor from the motor driver. There must be a loose wire here, possibly within the control board itself.

First thing I’d do is check your cabling and that the wires are in the right order and are secure: https://sienci.com/dmx-longmill/electronics/

If it persists, try plugging the X-axis motor into the Z-axis plug or try running a different motor cable from the X-axis motor to the driver

@chrismakesstuff I have changed the wires, and yes that does seem to be the issue. Now when I look at the one cable everything appears to be secure on the green end (attaching to the control board), the white end looks like the blue wire is not fully seated (https://photos.app.goo.gl/joPhHUjqxVzRFPz87). I am not sure how to get the wire properly seated, i tried to push on it but can’t get it to move.

Oh yeah that’s looks to be the issue. Might you have a small, flat head screwdriver on hand? You should be able to use something like that to push the connector the rest of the way in

@chrismakesstuff Thanks for the tip. I was able to get it pushed in with a lot of effort. Now the machine is working again. Thanks.

1 Like