Z is operating opposite after flashing gsender

hello, I had an issue with inactive jogging in gsender. Its was recommended to flash gsender and restore defaults. That restored the jogging function, but unfortunately, now my Z axis is operating inversely, up is jogging down and jogging down the direction is up. Is there a solution to this problem? The X and Y axis are operating normally.

Look at setting $3 in the firmware tool in gSender. Flip the Z axis there.


Thank you Michael, I will try that now and get back to you. I am a big fan of your youtube channel!

Also I can’t remember if you have mentioned homing or limit switches in your setup. If you use that stuff you will need to enable it. Pay careful attention to the machine until you get that stuff sorted as it may jog alright and but home in the wrong direction etc. Don’t have a youtube channel, but thanks!

hello Michael, I went to 3$ yet it really didnt offer an option without a warning, so I am still with this problem. X was toggeled to Blue, Y was off, and Z was toggeled to blue. but when I tried toggeling Z I got a warning and had to leave the settings as they were. Im new with this, can you offer any advise?

What was the warning? Was it because it’s the first time you’ve a setting in the firmware maybe? It’s ok to change the z on number 3, it will change the direction of the z axis. Just put the axis somewhere safe in the middle of travel and go slow to test it out.

Michael, my apologies, Jason just emailed me from Sienci support and pointed out to me I no doubt flashed the drive using the longmill 30X30 selection, I didn’t scroll down to see that my machine The MK 30X30 was listed! I redid the flash drive and restored defaults and ALL is working as it should now! Thank you for your help, now one more lesson is under my belt with no doubt many more coming.

1 Like

Glad your up and running!