Cant use the usg that I run before

I NEED HELP WITH UGS
I have used ugs before with great sucess.
I downloaded 2.09 snapshot 2021-11-24 and it worked fine.
now when i try to run it , it opens fine but i have the following problems
the program opens fine and all of the jog, home, toolbox ect work .
the screen shows a window ( SOURCE) that shows the actual G-CODE
the bar at the bottom shows ( no file loaded)
the run , pause , and stop buttons do not work
nothing shows in the visualizer
any help would be great

@wkcnc - First off welcome to the group Warren. I used to run UGS when I first started running the Longmill MK1. It had it’s issues back then and IMHO it is not well maintained. I then switched to CNCjs which was much better and lot less issues. Then along came gSender (from Sienci Labs) which is a total new system but based off of CNCjs. Sienci has spent a lot of time improving gSender over CNCjs. I would highly recommend you switching. The latest release is version 1.1.1 and seems very stable. Unfortunately I can’t help with UGS since I don’t use it anymore. Maybe someone else here on the forum, still using UGS, can assist you. Good luck.

2 Likes

thank you ,I am going to try gSender

2 Likes

@wkcnc Welcome to the forum! A great group of folks here, very willing to help! I agree with Heyward, Sienci gsender is rock solid and works well, even for a green horn like me. Let us know how you fare out with this. Again, welcome!
Jake

thanks Jake, I have downloaded gsender and am learning the usage. I still don’t have enough experence to really rate the software yet, but it seems to be a good program. the only problem I have found is that the 3018 is not in the set up. this is not a problem so far but is a minor irratent[quote=“wkcnc, post:1, topic:6245, full:true”]
I NEED HELP WITH UGS
I have used ugs before with great sucess.
I downloaded 2.09 snapshot 2021-11-24 and it worked fine.
now when i try to run it , it opens fine but i have the following problems
the program opens fine and all of the jog, home, toolbox ect work .
the screen shows a window ( SOURCE) that shows the actual G-CODE
the bar at the bottom shows ( no file loaded)
the run , pause , and stop buttons do not work
nothing shows in the visualizer
any help would be great
[/quote]

thanks Jake, I have downloaded the gsender and it seem to be working well. I still need to work with it more to know if it is a good fit
wkcnc

Heyward43
I have downloaded the gsender and I am working with it. So far it seems to be a good fit for working with the 3018 machine.
wkcnc

1 Like