Adding a Laser - My Journey (Tutorial)

@Incredz Justin: See my reply in my “solved” thread.

@Lumpy Well, Kris, I finally got to play with Lightburn today. I did get a few burns done, but my approach needs work. This is significantly different from routing.

I cannot get the laser to “dial down” so that I can get it set to where I want to start. When I press the button on the board, the light blinks, but the laser power does not seem to change. It still burns the wood. Likewise, in Lightburn. I finally found where to set it, but even when set to 0%, the laser burns. Did you have better luck?

Origin seems to be completely different than in VCarve. So far, I start the burn and very quickly move the wood to where I want it. I cannot seem to get it to start where I think it will. Back to the drawing (burning) board.

I have added a laser, too. I’ve added a few macros to UGS to turn the laser on to 5% power (still burns wood), turn off the laser, etc. So what I tried was setting X, Y and Z axes to zero where I wanted zero to be (i.e. the zero XY point in Lightburn, but that didn’t seem to work. So, then I tried positioning the laser where I wanted the XY zero to be and turned the LM control box off and on to set the Home Position to that point and also X and Y axes zeroed at the same point. This actually seemed to work. Once I had this all set I finally placed the wood I wanted to burn in place, fastened down and hit play.

One thing unique about using a CNC like the Longmill for Laser engraving/cutting is that there is a Z axis. I think that most dedicated hobbyist laser machines only have X and Y axes and probably behave more like a 3d printer with with homing switches to set X and Y zeroes. With one of these machines you would have to adjust the laser lens to focus the laser. With the Longmill I’ve been focusing the laser by moving the Z axis up and down rather than adjusting the lens. Once I have it focused I set the Z axis to zero.

@paullarson Paul: I’m glad to see that someone else has the same issue that I have about the laser burning no matter what the power settting is. It is still frustrating though.

I’m interested to read how you solved the homing issue. I may try your method as I can’t seem to get Lightburn to do what I want no matter what options I choose for zeroing the machine.

I’m also interested to read about setting Z0. I have not been setting it at all. I have the laser positioned about 2.75" from the material and I just leave it there without setting Z in the software. I figured - maybe incorrectly - that there is nothing in Lightburn moving the laser up and down, so Z0 is irrelevant. Do you find that Lightburn does move the laser up and down in Z? If so, what tells it how much to move it? Using a router, I set Z0 to the surface and set VCarve to cut to the depth that I want. I can’t get my head around how a laser works in this respect.

You may be right about not having to set Z zero, but Lightburn does have the ability to move the Z axis if you enable it.

You should focus the laser to get the smallest possible point of light. This is not that easy, but I think I’m starting to get the hang of it. The company I bought my laser from (Endurance) provided a thin business card size piece of black anodized aluminum to help with the focusing. It doesn’t instantly burn and flare up like wood so you can actually see the point of light (with laser safety glasses). Also, I’ve been using one of those cheap digital microscopes to look at the laser point. It works pretty well although it’s a bit clumsy. They have quite a bit of info on the Endurance Laser website about focusing and more.

Focusing is important to get both highest energy transfer and best detail in whatever you are engraving or cutting.

@Lumpy, great writeup!!! I just got my laser, a bit different, but should work well.

Do you have the drawing for your laser mount available? Saves me from starting from scratch on one! :grinning:

@djgrant181 Here is a dxf of mine, if that helps.

laser_bracket.dxf (9.1 KB)

Forgot to reply earlier, but thank you so much! I have to modify it a bit for bolt pattern on the laser itself, but this definitely helps!

Dave

1 Like

Hey Folks,

Just wanted to apologize for my absenteeism.

I had emergency surgery a few weeks back and I’ve been recovering slowly.

Kris

No apology necessary. Get well soon!

@Lumpy I’ll think good thoughts for your full recovery, Kris.

Holy Kris, great review. Just ordered my laser and I’ll be following along! Thanks for taking the time to do this!

Finally got around to setting this up and I ran through the wifi cutout tutorial on lightburn and seemed to work okay and I matched the settings in the tutorial video. What didn’t work was cutting out the piece from the plywood.

I’m using 1/4 inch BB plywood and I tried 20% to 80% power on the laser going 50 mm/s with 10 and 20 passes and it barely leaves a scratch. It certainly doesn’t cut through.

Any ideas? I tried exporting the gcode and ran it through ugs , I also ran it again directly through lightburn.

I dialed in the laser so it leaves a very fine point and it’s about 2 inches above the plywood.

Any ideas?

@justinbouchardw, what wattage is your laser supposed to be? 1/4" is pretty thick. 50mm/s is pretty fast. I have a 10W laser and I cut through 1/8" BB ply in 2 passes using 100mm/minute at 100% power.

it “says” 5 Watts… To be honest I’m not even looking to cut through 1/4 inch. I’m just looking to engrave with it but I was hoping it could burn down at least 1/8 inch or even 1/16 inch. At 80% power and 20 passes at 50mm/s didn’t do much more then scratch it?

Oh and I think I use 50mm/m not per second - that would be fast.

I engrave at 1000mm/min and between 35 and 45% power. I probably get between 1/32"-1/16", but I’m not trying for any deeper, and that’s one pass. If my laser is 10W and yours is 5W then I’d suggest cutting my speed in half or doubling the power. If you have one of the Chinese lasers they are a bit infamous for not living up to their ratings so keep that in mind. The other key thing is have the laser properly focused to the surface of the wood. You want the smallest possible point of light. Obtaining this is not quite as easy as it sounds because the point can be quite bright.

Thanks @paullarson - I slowed things down today and ended up with a nicer job. finding that point is pretty hard. I now have a piece of wood as a “spacer” to quickly move the z axis. so I don’t have to refocus that laser.

Just out of curiousity - where did you get your laser from?

@justinbouchardw, from Endurance Laser,

Hi everyone, I’m new here and tried to read up on all the history, so forgive me if I ask a repeat question.

I have been working to add in a Sainsmart laser unit that I had prior to the Longmill (in fact it was largely the inspiration to get a CNC)

I think this is the driver and laser it came with:

This is a 3 pin connector. I simply tied the grounds together from the 12 VDC power supply and the ground pin on the long board PWM . I then took the SpinPWM pin and connected it to the PWM input on the driver board and connected the 12 VDC to the third pin for power.

I then enabled laser mode and reset the max spindle speed to 100 in the GRBL code

The laser powers up just fine, but the PWM signal is not working right, the laser is always on. Here is a few things I tried/reviewed:

The SpinPWM signal with no load at all (just connected to a DVM) does not scale like I would expect:

M5 or S0 - .188
S20 - 2.83
S40 - 3.40
S60 - 3.88
S80 - 4.24
S100 - 4.46

Each of these commands I would expect to result in 1, 2, 3, 4 or 5 VDC, but they didn’t line up that way. When checking the no load output from the Sainsmart GRBL board on the PWM, I get:

s0 - 0
s20 - .96
s40 - 1.87
s60 - 2.78
s80 - 3.69
s100 - 4.57

Another thing I tried is to simply hook up power to the laser and leave the PWM input floating, the laser came on, even with no signal on the PWM. If I tied the signal to ground, it turns off, so the driver seems to need to be pulled down to ground on the PWM input.

One last test I did was to wire in the unit with taps, so I could measure how once it was connected to the Longboard it responded. In that case the S0 command really went to 0 VDC on the PWM while the power switch on the driver board was off. Once the power was turned on, the voltage jumped to 4.5 VDC, without changing anything other than powering on the laser module.

I’m totally scratching my head on this one. The module is good, it works fine with the Sainsmart GRBL board, but somehow it does not play well with other controllers.

Has anyone here used a 3 pin laser successfully on the Longmill?