Any issues on putting control unit on right side? Longmill MK2

Hi all. New to the forum.

I have an issue with my longmill mk2.

I put it together watching the video on youtube. The only thing I changed was putting the controls on the right side instead of the left. X-axis motor is on the right.

Using V-carve Pro, I made a simple 2" square’s graph for the spoilboard. zeroed front left corner of my project (graph), and ran the program. It started from front left towards the back 30 inches, and then it was supposed to turn right 2" and then back. It turned left and I stopped the machine. It wanted to do the project off the left side of the table. So then I zeroed off the front right of the project, and mounted it to the front right of the table, and ran it. It did the whole graph , but on the left side of the Y-axis.

I then ran a small program with some text on it. And here is how it came out zeroed on the front right.

If picture doesn’t show, the text engraved backwards and upside down. Tried zeroing on front left corner, and it wanted to engrave off the left edge of project.

Is this all because I put the controller on the left. Checked all connections.

Any help? Thanks, Steve

1 Like

First of all, welcome to the forum @cncuser ! Good folks here, willing to help. I have a couple of questions for you.

  1. Does the project look correct in vcarve pro when you run it? If not, fix the issue there before moving on.
  2. How does the project look in GSender? Have you used the test run? If you did, how did it turn out on the screen?
  3. If you jog your machine front to back, left to right, does it work as designed?

I’m thinking your issue is in vcarve pro, but without being there, it’s hard to know. If it is correct in vcarve pro, maybe your issue is a GSender radio button causing it to be backwards and upside down?

If I missed anything, someone with more experience than me will chime in. Please, I’d appreciate of you figure it out, post your solution here. It may help someone else with a similar problem.

Once again, welcome!

@cncuser Since you mounted the X motor on the right side, you need to go into gSender and reverse the X direction. Go into step direction invert for the X axis and turn it on.

1 Like

Thanks Jake and gwilki for answering the post.

UPDATE: All is good. I did what gwilki recommended, and poof problem solved. Everything is moving like it should, and I have letter’s that aren’t backwards,lol.

I didn’t read or see any documentation on doing this procedure if you want the longbox on the right. Might be a good one for the suggestion box.

Having a problem with com3 disconnecting. Still researching that one.

Thanks again for solving the issue.

1 Like

@cncuser I’m glad that things are working properly now. Just to be clear, you can put the control box anywhere you like, with no changes needed to the firmware. Your’s needed changing because you installed the motor opposite to the default position.

As your issue is resolved, I’m closing the topic. If you continue to have com port issues, don’t hesitate to start a new topic.