CAMLab link issue

I am preparing for my upcoming order and want to get used to software. When I click on “Let’s Go” link for CamLab on this page:
CAMLab it takes me to feeds and speeds, not the software. Is there a link issue?

@msparks916 Welcome, Michael. When I click the link in your post, I get a page with a button that says “let’s go”.When I click “let’s go”, I get the following:

What browser are you using. I’ve tried in Firefox and Edge and I get the same page.

1 Like

I am using Chrome and it shows different. I will try a different browser. Here is what I actually see with Chrome:

Ok, the image is not uploading but it takes me to a graph/chart of feeds and speeds instead of CamLab.
Just validated (should have thought about the browser - doh) it works in Firefox, but not Chrome.

1 Like

@msparks916 I’m glad it worked out. I didn’t check in Chrome. I google-phobic. :upside_down_face:

1 Like

Apologies for the jpg size.

@msparks916 - I use Chrome and it works for me. That’s weird.

Do you know what version? I cleared the cache and still doesn’t work in my Chrome Version 87.0.4280.88 (Official Build) (64-bit).
At least I can use another browser.

FYI - Works in Edge as well!

This is my current version - Version 87.0.4280.88 (Official Build) (64-bit). Same as yours.

Well. Got a couple of system updates today, a browser restart request, and a reboot request and lo and behold, it is now working in Chrome. thanks for all the replies - issue resolved.