Computer Driver Issues

I’ve been trying to get this going for 2 days now without luck.

I was running my Longmill off an older laptop for the last little while. The plan was to use that until the weather warmed up and I could transfer a desktop I have out there. The laptop took a good 45-60 mins to boot up each time and ended up crashing on me halfway through a 16 hour cut so that gave me the motivation I needed to switch it out.

I cannot seem to get the Longmill to connect to this PC, though. Here’s basically everything I’ve tried so far - multiple times.

  • I’ve uninstalled the drivers multiple times, letting them reinstall themselves on a computer restart. Sometimes a window pops up saying it’s setting up the drivers but it always seems to crash. Other times nothing happens at all. I’m thinking this crashing driver install is the problem.

  • I’ve downloaded the Adruino drivers and installed the IDE program.

  • I’ve tried a different computer that has never been hooked up to the longmill to rule out the machine - it worked fine. I can also still connect to the old laptop but it’s so slow it’s very unusable.

  • I’ve uninstalled everything (Adruino IDE, gSender, drivers - all usb and port), restarted, and reinstalled one thing at a time.

gSender shows the longmill in the connection dropdown as ‘unrecognized device’. Clicking connect shows it connects in the top left but won’t allow any of the jogging controls to be used and says disconnected in the top right of the 3d preview window.

Does anyone know anything else I could try?

My next thought is to completely reinstall windows 10 and start over but that is a long process that might not do anything so I’m hoping someone might have a few more things I could try first.

The crazy thing is I have hooked the Longmill up to 4 other computers with absolutely no issue. Go figure when I try the one I actually need it to permanently run on, it doesn’t work.



Just a shot in the dark, but do you have Java on the PC that doesn’t work? The latest level?

I did also try Java install and forgot to mention it, thanks. I’ve gone through the Sienci common issues page and tried all the steps there a few times - java install being one of them.

As an update from trying so far today, it seems to be this crashing of the initial drivers install.

If I completely uninstall everything and plug the Longmill into the usb, this window pops up immediately and doesn’t go any farther than that. I have uninstalled everything enough times that I can get it to this point each time, consistently.

I’ve left that driver install screen for quite some time, and it’s currently sitting like this now.

The next thing I’m going to try is to completely remove everything, including all the other drivers that I can. I’ve got a bunch of mouse and drawing tablet drivers that I haven’t taken off yet, so that should rule out if any of them are the issue, I guess.

@stephen.king989 A couple of things that could try. You don’t need Java if you are going to use gSender. UGS needed Java.So you could uninstall Java.

Second, start windows in safe mode and see if it can connect. If if can, you will know that you have a driver conflict and can work from there.

1 Like

Thanks, this might have just pointed me back to reinstalling windows.

There was a point where I tried to reset windows in the settings menu and that also wouldn’t work. I ended up moving on to other troubleshooting.

You’re comment about going into safe mode brings me back to that. I tried to restart in safe mode and it won’t let me do that either. Both holding ‘shift’ and trying to restart through the recovery settings both only give me an option to turn off the computer. There should be multiple options - safe mode being one of them. I also can’t do other things like change the system language, so the computer has some issues.

I’m going to look into making windows install usb key to try and completely reset it as my next step. Too many weird things going on with it.

1 Like