Fast Travel buttons

i really enjoy the fast travel buttons under the homing button that quickly jog to the far corners of travel. i just received a Shapeoko HDM and have been testing gsender and noticed an issue. When using one of these fast travel buttons i’m getting a limit switch error. maybe instead of riding the furthest limits of travel it could go within the homing pull off distance? so for example when clicking front right travel after homing the machine starts at x-3 y-3 z-3 but it attempts to travel to x0 y-535 z-1 and this is causing it to hit limit switch (proximity switches) It would be preferable to travel to x-3 y-535 z-3. maybe an alternative would be allowing the buttons to be programmed by user to a specific location. hope this makes sense. please let mw know if clarification is needed.

This won’t make it in to the upcoming release but we’ll look at it in a future release.

Longmill firmware is configured slightly differently than standard GRBL in that it sets machine 0,0,0 on homing completion to whatever corner you homed to. The side effect of this is that you can go to X0 since it will be away from the limit switch since M0,0,0 is set after the pulloff distance - you “lose” the pulloff distance as workable area but it’s so small it doesn’t matter.

Obviously this works well for machines running our firmware image but won’t work for standard GRBL. We’ll look at moving to $27 off (axis)0 instead of just (axis)0 to make it more consistent for all machines in the release after next. Going to a non-0 location should work fine currently since we move to a percentage of the limit, not the limit itself.

Thanks for the response,

1 Like

perfect. and that does make sense. Thanks for the quick response. I’ll just avoid those buttons for now.

I thought the fast travel buttons were based on your GRBL settings.

|$|X Max travel, mm|
|$131=yyy.yyy|Y Max travel, mm|
|$132=zzz.zzz|Z Max travel, mm|

I just tweaked the settings on my Shapeoko3XL so I had no issues. I have not seen any issues when using Carbide Motion, but I have not looked too closely at it either.

Ahh rereading the original post and I can see your issue… I don’t remember anything like that happening to me, but I’m on the old switches.

Yeah I’m not having the issues with Carbide Motion manually going to those locations like x0 y-535 using the MDI but get them with gsender fast travel buttons. Adjusting GRBL settings doesn’t address this issue. Also there’s no error at front left fast travel opposite of homing position where no sensor is activated. I’ll just avoid them for now or make some macros to go to preset locations.

We’ll have changes aimed at this in the next release, thanks for you feedback - I’ll post again closer to release and see if it’s cleared up on your end.

I was using my CNC machine today and was notified by gSender that an update was available. I go over to github to see what the changes are and see the following listed as one of the changes:

Rapid position buttons should now account for machines not running Sienci-specific firmware and offset position from 0.

So I installed 1.0.6 but I don’t see any change in this behavior. I have a Shapeoko3 from 2019, but going to the rapid home position still goes to X=0 and Y=0. Is there a setting somewhere that I missed?

1 Like

I’ll follow up with @KGN and see if that fix wound up being implemented, Steve

I can confirm I’m still having the issues

The fast travel buttons in 1.0.7 now work for me on my Shapeoko! Thanks for the update!

1 Like

Neat, at least one thing works in 1.0.7!

Thanks for following up, I’ll close this now.