Firmware Update Failed

Hi All,

Looking for some help with my firmware, I recently ordered the inductive sensors and was following the install guide which has you flash GBRL on the machine, the instructions worked, and I was able to view the EEPROM settings afterwards. The next time I connected the machine made the clunk noise, shows as connected (COMM 4 BAUD 115200) but there was no option to jog.

I downloaded Arduino noted in the firmware update page, show as being connected, the Board Info tab shows a board, S/N, etc so it is registering the controller but Tools > Serial Monitor show no firmware on the device. Trying to flash again in gsender gets the notification for it starting and then 10-15s after a notification pops up [object Object] and nothing happens.

I tried flashing using Aduino, EEPROM clear code uploads and runs properly but when Uploading the library it fails and provides this error (i have tried all three releases of the firmware)

Any help would be appreciated

Arduino: 1.8.19 (Windows 10), Board: “Arduino Uno”

In file included from C:\Users\Longmill\Documents\Arduino\libraries\grbl/config.h:30:0,

  •             from C:\Users\Longmill\AppData\Local\Temp\arduino_modified_sketch_918406\eeprom_clear.ino:1:*

C:\Users\Longmill\Documents\Arduino\libraries\grbl/grbl.h:68:4: error: #error “Required HOMING_CYCLE_0 not defined.”

  • #error “Required HOMING_CYCLE_0 not defined.”*

  • ^~~~~*

C:\Users\Longmill\Documents\Arduino\libraries\grbl/grbl.h:108:4: error: #error “WCO refresh must be greater than one.”

  • #error “WCO refresh must be greater than one.”*

  • ^~~~~*

C:\Users\Longmill\Documents\Arduino\libraries\grbl/grbl.h:111:4: error: #error “Override refresh must be greater than zero.”

  • #error “Override refresh must be greater than zero.”*

  • ^~~~~*

exit status 1

Error compiling for board Arduino Uno.

This report would have more information with
“Show verbose output during compilation”
option enabled in File → Preferences.

First off welcome to the forum!

Do you have the hex file to load or are you compiling from source? I ask because I recently flashed grbl onto my ATMEGA2560 using XLoader and it was super simple compared to Arduino IDE. (646.7 KB)

I think I got it from here.

Hope that helps or someone else chimes in. Let us know how you make out.

Thanks Michael,

Turns out I was just rushing in my concern and missed the step to open the " grblUpload.ino" file.
Reread it tonight and caught my error.

Cool, glad you got it worked out.

As the original issue has been addressed, I’m closing this topic. If anyone else has a similar concern, feel free to start a new topic, which will ensure that it is addressed promptly.