First build. 200mm Lead Screw Problems

I just got my machine and am only a short time into assembly. The 200mm lead screw will not fit inside the flange bearings for the motor mount. Maybe the bearings are a hair small? The slip in and out of the motor mount very easily. I have tried using quite a bit of force including (delicately) vice clamps and a hammer. Please help! Assembly has stalled.


@mid_al Something doesn’t look right. The bearing shouldn’t be sticking through like that. The correct bearing is in the upper left corner of the picture next to the lock nut. What is the piece sticking out?

The lead screw was passing through the bearings at different rates and then the bearings would stick in place as it did. That’s what you see sticking out. One of the bearings. I was able to place all pieces correctly by tightening the lock on a lock bolt and turning another bolt along the lead screw until all were in place. I did this on both sides of the motor mount as I had to tweak it back and forth at touch. There is no damage and everything is where it should be. It was still an extremely tight fit.


it was sticking in all bearings. I tried all that were included. I have solved it as stated above. Thanks!

1 Like

@mid_al I’ve deleted my posts, as we were posting at the same time and you solved it without my questionable help.

1 Like

I think I would contact Andy or Chris at Sienci. That doesn’t sound right. Jump back in Grant. What do you think? Lead screw should just slide through bearing easily. And to come apart like that is not good IMHO.

@Heyward43 I’m not sure, H. Clearly, that short rod was too tight in the bearings. Once in, though, I would not think that it would affect anything. When the pulley is attached to the rod on the top and the lock nut on the bottom, the rod does not move in the bearings; the bearings spin.

All that said, I guess the only thing that could go wrong is if the rod is not really “stretched” between the two bearings as it should be because it is binding in the bearings. If that were the case, over time,things would likely get sloppy.

There is no sign of binding. Everything seems to move smoothly and stays in place now. I was able to get some movement between the bearings and lead screw after the initial push with no damage that I could see. I’ll shoot them an email so there is a record, but I feel pretty good about the assembly now. Thank you for the advice!


@mid_al Glad to hear it Michael. Have fun.

1 Like

I have the same issue. Mine will not go through the flange bearing either. One is too big or one is too small.

Same issue here. It look like the upper bearing not sitting well on the flange and tue metal brace isn’t flat with the 3d print support. I’ll take picture today. When I tight all bolt I see a little gap between 2 parts. I tried to fit the bearing with a vise. The lead screw turning well until I lock the acme nut I have little resistance when turning exactly at the same place when I handly turn the lead screw. It looks like the acme nut not sitting weel on the bearing cup.

@GuillC @TOPMO
I was able to get my lead screws all in using two lock nuts. I would lock one in place and use vice grips or similar to hold it in place while tightening the other nut against whatever object I was trying to move, using a wrench to turn the moving nut. It was a slow process, but worked. My machine is running great. I had issue with all of the flange bearings and one of ?tension nuts?..the robot heads. It added an extra hour or two to the assembly, but I got there eventually. Good luck!