Flashed GRBL No back-up dead machine

Let me preference this question with the fact that I’m a Retired 63 yo Newbie with a new CNC4Newbie New Carve 1045. Downloaded gSender recently to try it out, really nice software. Decided it was a good idea to flash GRBL without creating back-up first. Thereafter the machine was not behaving normal, so I modified a few g-code settings as provided by the CNC4Newbies folks and Phil Johnson Demon Controller. XYZ movement will stop jogging randomly, will not home. I have tried everything with the g-code i should be right and at this point think it’s an firmware Arduino issue? If that’s even a thing? Any help would be greatly appreciated.

Can you post your gcode settings for us to look at?

@Councilbob WE need more info. What controller are you using? According to the cnc website, there is more than one available. I suspect that you flashed the arduino in yours with a Long Mill eeprom. If that is the case, you need to get a proper eeprom from the controller supplier.

Thanks for the reply. The following is from gSender firmware tab export settings

Setting Value
$0 10
$1 255
$2 0
$3 0
$4 0
$5 0
$6 0
$10 1
$11 0.020
$12 0.002
$13 0
$20 0
$21 0
$22 1
$23 7
$24 25.000
$25 750.000
$26 250
$27 1.000
$30 30000
$31 10000
$32 0
$100 133.333
$101 133.333
$102 50.059
$110 4000.000
$111 4000.000
$112 2000.000
$120 100.000
$121 100.000
$122 100.000
$130 900.000
$131 1315.000
$132 175.000

gSender 1.2.2
OS: Windows NT 10.0; Win64; x64
Machine Profile
ID: 41
Name: CNC4newbie
Version: undefined
X Max: 900
Y Max: 1315
Z Max: 175
Spindle/Laser: false
Laser Mode Enabled: false
Available Ports:
port: COM4
manufacturer: Arduino LLC (www.arduino.cc)
inuse: true
Connected Port: COM4
Baudrate: 115200
Unrecognized Ports:
port: COM7
manufacturer: Microsoft
inuse: false
port: COM8
manufacturer: Microsoft
inuse: false
port: COM5
manufacturer: Microsoft
inuse: false
GRBL Information
Type: Grbl
a: 0.000
b: 0.000
c: 0.000
x: -75.000
y: 165.000
z: -39.993
a: 0.000
b: 0.000
c: 0.000
x: -628.198
y: 159.503
z: 58.207
Sender Status:
Tool: NULL
Workflow State: idle
Homing Flag: false

gwilki, I think you hit it on the head. It never dawned on me that the “Flash GRBL” would be specific to the Long Mill and would not be compatible with my third party machine. The controller “Demon Controller” was built by Phil Johnson and was an option when I purchased the CNC4Newbie New Carve 1045. He has since discontinued production of the controller. I did email him with the same question I posed to this forum and to date has not received a reply. I do appreciate your help and I feel better about the 2-300 lbs. of aluminum sitting in my garage making a comeback, as it was working flawlessly prior to my poor decision.

@Councilbob As you have already surmised, the setting that you printed out from gSender merely tell you what it wrote to your controller.

I just did a net search on cnc demon controller and found links to the loader that may well put the proper settings onto your arduino. I emphasize that I am not endorsing this. :grinning:

Here is one link

You will see links on their to xloader files and hex files. These may well be what you need.

1 Like

gwilki, Thank you so much, it’s back to it’s former glory and working fine. xloader worked quickly uploading the hex file, only had to modify a few codes specific to my machine and we’re off to the races. Thanks again!

1 Like

@Councilbob Happy to help. I’m closing the topic.