Fusion 360 g-code problem

I’m having trouble with my g-code. When I load my g-code. The bit does not rise up and cuts through my wood. Then cuts with no problem. And then after is cuts through my wood again. Lol. So I clearly have a setting or maybe a few setting wrong but I’m not sure what ones. My zyx is set up and the simulator runs fine in fusion. Any one have any tips for me?

Not familiar with Fusion 360 but is there a setting for or called “Safe Z”? This would represent a safety height for Z movement when not cutting.

Yes there is. I will check that height.

Should my safe height be the same as my clearance height?

I think it has something to with G28 safe retract. But I’m not sure what that means.


On the settings page for your setup, set your zero on a convenient box point. If you will change tools, choose a spot that won’t disappear during a cut. I generally use the center for circular stock and bottom left for rectangular. You can use the table or another off-stock location for Z if most of your stock is getting cut away. Make sure you set your stock up with top and side offsets if needed.

On the heights tab on the toolpath setup page, make sure your bottom height is set correctly - If you will contour cut down to the bottom of the stock, set the bottom height to stock bottom. Add positive or negative offset to adjust this - If you want to cut through into the support pad or foam like I do, use like -0.015". If you want to keep the tool away from the bottom so you can’t go all the way through, use +0.015". If you’re only doing shallow pockets, switch to the stock top and add a negative offset equal to the pocket depth. F360 uses all these numbers to be as accurate as possible, but also to avoid unnecessary tool travel and wasted time.

When you post your job, check a couple things on the Post Process window. Under Property, make sure Safe Retracts is set to Clearance Height, NOT G28 or G53. This will raise the cutter to whatever you have the clearance height set to in the Heights tab in the toolpath setup, and will not move in the X or Y direction. You probably want Output M6 (tool change) set to No, and Output Tool Number (lists the tool number in use in the gcode - good for error tracking) set to Yes. The Property values I use are: Yes, Yes, 1, 10, No, Yes, No Splitting, Clearance Height, No, Yes, Yes, Preserve rapid movement, 0, 1000, 0.25, 0.01, and 0.002.

When you’re ready to run, after you’re set the cutter to the zero that matches what you picked in your setup, but before you you hit Start, raise the cutter 0.1" or so so it can’t drag when you start.

Figuring these things out is what what makes this fun. There are people here who are better at F360 that I am, so ask for help when you need it. Enjoy.



Thanks Bill
I will work through your post and check my settings. And we will see how it goes.

I have been adding a line to the code generated by selecting open code in editor = True in the properties on generation.

In the code after G54
add a line G0 Z1.0 (assuming inches) If you are in mm add 2 mm perhaps, this will bring the Z axis up before the tool moves to travel to the first point to cut.

Ok so when i did another cut. This time the bit lifted up. Moved to the start position. And then went right to bottom height. And ripped the piece off the table. I hit the “oh shit” button. Now the whole gantry is lose so I’ll have to adjust everything. Oops. Anyways so now I’m looking into why this happened and I think maybe it’s because my code was in inches and my LongMill is set to mm? Would this make it do something crazy like this?

The code will have a line that sets the units of measurement near the beginning, so the controller will work correctly.