Fusion 360 Post Processor Issue

Hi all. I’ve been using the Arduino simulator and testing G code output from Fusion 360 on UGS and found a consistent problem. Fusion wants to add a line specifying the tool number and spindle speed, neither of which UGS and GRBL will tolerate. You can edit the line out of the code every time but that’s a drag, and there are no sttings to turn the output off. I found an Autodesk solution by Seth that includes a new GRBL post processor for Fusion. You merely download the file and replace the one currently in Fusion. Works great. If you want the file either search Autodesk help for the ‘tool and spindle speed problem’, or let me know and I’ll forward it to you.
Have a good one.

1 Like

You can take that line out when you open it. I cannot remember how exactly Andy and Chris know for sure. You open the file take it out and resave it then you can run it in the UGS.

If you change the post processor, which takes all of about 2 minutes, you don’t have to edit anything. And it’s from an AutoDesk expert, so it’s stable and works.

Thank you - just grabbed that file, will give that a try, really appreciate the info.


Do you still have this file? I can’t find it at Autodesk.

I think thats the mentioned file: https://cam.autodesk.com/hsmposts?p=grbl&_ga=2.248819983.903377985.1586582301-1290965133.1586582301

The corresponding discussion with file link on page2 is here: https://forums.autodesk.com/t5/fusion-360-manufacture/looking-for-a-working-correct-post-processor-for-grbl/td-p/8713533

I think the file JHahn listed is the latest one. If you message me with an email address I can send you the one I referenced. It’s the one from 9/2019 and it’s the one I still use.

Ok, yes I updated with this file and the problem remains.

Make sure the file name is grbl.cps. Go to c:\users\yourpcname\AppData\Local\Autodesk\webdeploy\production. Find the newest folder with the 40-character name like 5d5b542f5ddb82dac8b734aa2cb375dc33c4efb2. In that folder go to Applications\CAM360\Data\Posts. Rename the file there so you can find it later if you want to go back, and put the new one here. Important - Re-start F360. You should be good.

You can make UGS ignore other G & M codes by clicking on Tools, Options, UGS, Controller Options, and enabling the pattern removal of the codes at the bottom.

Let me know how you make out.


I looked more closely at the file that JHahn referenced, and it is NOT an updated version of the one I referenced in my initial post. If you are still having trouble I can send you the file I discussed.

Yes please. zachbortiz@gmail.com

Thanks for the file. Unfortunately, the problem remains.

Is this the grbl file you’re using?