gSender 0.6.8 Release: Feedback Thread

Ok y’all I’m a bit delayed on this as the past week has been chaos, but we actually release another version of gSender only 1 week after releasing the previous one. Why, you ask? Well there were some changes that came with 0.6.7 that we thought were good to go but caused some rather unexpected issues so with a lot of feedback over the weekend and a list of bugs we trudged forward to create a new release by week’s end! Let’s take a look at the new changes: @trust_level_0

What’s fixed?

  • New macros not appearing for shortcut assignment
  • Shortcuts not working properly
  • Keyboard jogging running away or not continuously jogging
  • Handling M0 commands (should avoid issues with programs like Carbide Create)

The final bigger issue was that the File load button sometimes wasn’t working. We’ve since found the cause for this is running the updater while not connected to the internet - weird right? Well in the meantime that’s how you can fix it if you’re still having that issue, but we’ll have a fix put into that on version 0.6.9 which should be ready in a few weeks time.

Since this release was more -impromptu-, the remains of this post will be similar to the previous feedback thread.

Things we’ve got our sights set on for the next release:

  • Still more improvements to performance by streamlining data parsing and manipulation to improve reliability and reduce possibility for data leaks (enabled worse hardware to run larger files more reliably and smoother operation of gSender as a whole)
  • Joystick control
  • Run outline prior to job operation
  • Start from a specific gcode line to save projects gone wrong

Topics I’ve noticed feedback on that we’ll be looking to address soon:

  • Headless Pi operation
  • More guidance for first-time users
  • Manual value entry for X, Y, and Z locations

I’m happy that we got these fixes out in just one week, a big win that I’m happy for our team. This was another super productive past two weeks for the gSender development team. New documentation is still on it’s way to the gSender resources so watch out for that:

Most builds up to this point have been relatively stable but we just dropped the ball a bit on this most recent one. We’ve removed auto-updating so that from here on out you’ll have the choice to install the latest version at your own discretion. I know that gSender is still in Beta so to a certain extent these issues are to be expected, but we also hope that you guys haven’t lost the trust in our work as we continue development moving forward. We’re fast approaching Version 1.0 which will mark the completion of Beta and will mean that gSender’s core functionalities will be very stable from build to build.

If you’ve encountered any bugs or have feedback on this new release, let’s discuss!

Happy Thursday everyone!

3 Likes

Just me or is XY zero not really zero in the visualizer?

I’m not sure I understand the question or the statement

In the visualizer, the apparent origin is offset from the grid lines. Not a big deal, but…

I thought I had the old 06.7 version installed, but nope. It’s 06.8. And it still has the same M0 issues as it did with Carbide Create. Just an FYI. Also still tends to drive the bit into the workpiece when precise jogging the Z, no matter how long I wait between clicks of the mouse. Oh, but now the Start Job isn’t working. It always worked for me before, although I’d have to let it pause, then resume program.

I’m not trying to say that this is the answer to your problem but something for you to look and see if something that you see

I’ve had a lot of issues in the past where I issue a command on the keyboard the head starts moving and when I let go of the keyboard the head still continues to move.

I did notice that when this does happen he indicator on the screen never changes from jogging to idle

Just a recommendation for you that if you can add the extra comments.

I understand what you’re saying but it isn’t the issue of it indicating it’s jogging and I’m too impatient. I’m waiting for it to do its thing, then clicking again, and only once. I’ve tried waiting for 5 seconds with the same result. All of a sudden the Z (and ONLY the Z) will plunge without provocation.
I’m simply reporting the issues here for Chris and the team to hopefully sort this out going forward. I mention it because this seems to be an ongoing issue that while addressed, continues. The jogging issue I can work around, the not loading of files or the M0 error code should be worked out.
Update: I’ve restarted gSender and it now loads the file, albeit with the M0 code.

@Billy_Jack Bill: Is the pc that is connected to your Mill on the internet? Strangely, if it is not, that has been found to be the “load file” issue. Chris reported in this discussion that it will be fixed in .6.9.

What is happening when your Mill reads an M0 command in .6.8?

Yep. And I’ve seen your posts about that too. It’s connected. Oddly I’ve never had an issue with loading files on any version of gSender until today. It flashes the M0 a second after starting either a test job or real one. I just hit resume and all is well. More of an annoyance than a problem.
Like I said, I’m not really looking for fast solutions; I can troubleshoot and get the job done. I just would like the powers that be know that this is still an issue.

Okay Billy so first of all I want to say I am not implying or passing judgment on how or what you’re doing.

I understand what you’re saying and my suggestion was not to apply that you’re impatient or not waiting.

My comment was to probe you to provide ancillary information about what’s going on the screen.

I think I said this to Grant maybe not in as many words but I am of the belief that we report everything that we find as verbose as we can while keeping it realistic and informative

And allowing the powers that be to decide what’s an issue and what’s not.

I am nobody in the grand scheme of what’s going on in the development team here. I’m just trying to relay my experiences and see if what I’ve seen might be similar.

I believe Grant has been approaching things the same way is that he’s adding a second voice into what you’re reporting to try and add value to the information you’re providing.

1 Like

What issues are you seeing?

@Menglor Thanks, Stephen.

1 Like

Weirdest thing with 6.8, I was running gcode and all of a sudden, the visualizer went blank. Program continued and finished, but this is a first time I have seen this.

@msparks916 That is weird, Michael. Did all of the other screen displays - jogging buttons, menus, etc stay on?

Everything else (although, I didn’t look for finite details) appeared to be fine.

PS - not sure if it is related, but have had monitor flicker issues during hot days, but the whole screen is affected, not part.

If it does it again, I will take a pic.

1 Like

Encountered 2 issues over the weekend…Using the Linux Version.

  1. (this one I actually have found over a few versions)
    While jogging with the mouse say for example I have it set to .5 " I will click jog(doesn’t matter what Axis) .jog jog jog (and its a random number) instead of moving .5" it will jump like 2"(this is a random number)
    if I jog too many times it will just make these large jumps . I need to jog a few times rest then jog again to avoid these large jumps.

  2. While surfacing. I was using a 0.87" wide bit and the surfacing app/wizard it won’t allow anything smaller than a 1". I changed the overlap to 50% to make sure it would cover the overlap.

@Billy_Jack This Z movement has been an issue for me since the Alpha testing. It was reported several times in the feedback, but it has continued to happen. Unfortunately I am down right now until I get settled in my new place and haven’t used gSender for over a month now. To @Menglor’s point on reporting everything you see, it is difficult to see what the screen is doing when your Z takes off into your board or touch probe and you are scrambling to stop it.

On the other hand one time I was watching the screen and didn’t notice anything. It’s almost like a keyboard buffer is holding more mouse clicks, or the distance parameter suddenly increases and zooms off into your work. It only did this in precise mode, but that would make sense as you get it close then go into precise and start clicking away to get it down to the spot.