gSender Edge 1.2.5

Hey folks,

We’re at the point in EDGEs life where we’re mostly focused on improvements to performance and hunting down any remaining bugs. This version is largely that - going through our backlog of reported issues and making sure they’re handled.

That said, I’d like to highlight specifically some major improvements to file parsing/loading and visualization - we’re seeing 200-400% faster parsing and about 2/3rds less memory usage on some larger files. We also (finally) have a progress indicator when handling larger files.

As always, thanks to everyone who has reported issues or given feedback on EDGE - we’ll continue to work through our backlog, and are excited to release it to the general public.

  • New File Loading indicator that also includes progress
  • Significant improvements to file parsing to increase speed and reduce memory usage on large files
  • Fixed issue with laser offset and differing preferred units and file unit modals
  • Altered connection workflow to be more forgiving for non-standard startup messages
  • Fixed bug with feedrate unit conversion parsed from file
  • Fixed issue with reported bounding box not handling relative movements correctly
  • Fixed bug with feed override shortcuts
  • Firmware flashing modal now only shows Sienci profiles for flashing
  • Shortcut improvements to help consistency with migrations from version to version
  • Shortcut printing now works again
  • Dependency upgrades



Today I tried gSender Edge 1.2.5 on a Debian Bullseye system and loading files usually (3 out of 4 times) fails. I tried both .deb and AppImage installs and got similar results.

Before attempting to load files, I’m able to connection to my system (OpenBuilds BlackBox) home the machine, etc.

I’ve had good luck with 1.1.7, but this is my first attempt on a recent EDGE version. Are there log files I could provide to help troubleshoot?

osh@DebSender:~/Downloads$ hostnamectl
Static hostname: DebSender
Icon name: computer
Chassis: solo
Machine ID: e6a0119df0b44c6d96686e0db1155e8b
Boot ID: ea7200af3cb3479bb8141f1eb9a9118d
Operating System: Debian GNU/Linux 11 (bullseye)
Kernel: Linux 5.10.0-21-amd64
Architecture: x86-64

Thanks Kevin, both versions edge ver 1.2.5 and gsender 1.1.7 work fine the original longboard.

AND both gsenders versions now work with Fluidnc ver 3.6.8, as well as 3.6.9 which is nice for me!! so fixing the start-up messages probably did that, regardless thanks.


Playing around with 1.2.5-Edge an d finding that I cannot set some of the firmware settings. In particular I’m trying to change $100, $101, and $102 and it keeps defaulting to 500 regardless of what I type. For instance, I’m trying to enter 100.00 for $102 and every time I enter it it changes the value to 500. Don’t know if this is a known issue or not. Also seeing similar issues with some other settings.

Hello and welcome back…
What machine do you have and have you picked it from the available models listed??


I assume this question is to me. I have a Onefinity and have used 1.1.7 with no problem. I like some of the new features in the Edge version so starting to play with that. I just installed the upgraded Onefinity Z slider which uses a 1610 screw instead of a 1204 so I need to change the $102 value to change the Z axis travel revolution. I cannot type in the new value that I want to use as the form will simply ignore whatever I type in and replace it with 500. I went into my settings backup file and manually changed the $102 value and reimported the settings file and it worked fine. But, it seems like I should be able to open the Firmware settings page and change the values directly on that page.,


I just confirmed the bug with my test Arduino. Actually the bug seems to be with all of the text input boxes.

gSender 1.2.5 EDGE
Windows 10
Arduino MEGA 2560 running GRBL 1.1

1 Like

Hello everyone!
Has the problem running with Firefox been fixed?
Can you have just the controls and not the Visualizer showing? Using a phone just does not have room for both.
Thank You!

Good question ! Under settings menu select visualizer , you appear to be able to turn off the visualiztion in both regular and light weight mode for a number of options, however I have never tried these out.

I had a few initial issues with the Autozero Probe in Edge 1.2.5 where it touched down on the Z, then went hard left and tried diving through the plate. I finally have that working now after going back to the original in the settings, closing everything down, restarting gSender again, and then re choosing the Autozero.

The only other thing that is acting all crazy (but works in 1.1.7) is my joystick (xbox type). It recognizes that it’s attached, moves and seems to disconnect again. If I close Edge, and open 1.1.7, it works normally.


Would this be on the main computer or the phone that you would change the settings?

I would think that since the gSender Edge is in control, that is directly connected to the contoller, I would be tempted to try making the changes there on your main computer as you say.

Hey all, with the release of gSender 1.2.0 this thread will be closed and all following discussion can happen there :slight_smile:

Sorry if some questions or bugs weren’t addressed, if you find they still exist in 1.2.0 then let us know on the linked post and we’ll get right back on it :+1: