gSender Public BETA release is here!

Hi all, I just sent this out as an email but I couldn’t help myself from sticking it here onto the forum as well: gSender Beta is now Public!

This is a really big milestone that I’m really excited to have reached! It’s not easy or inexpensive to be paying nearly 4 peoples salaries for coming up on 5 months just to develop a program that is being made available for free but we just really think that this labour of love is going to be something that benefits not just the LongMill community but the Hobby CNC community at large.

So I guess now is the time for me to answer the two big questions:

  1. Why now?
    Though the changes between our release last week and this week aren’t drastic it’s never really clear cut when something is ready to move onward. Since this was my call, I can say that I didn’t want to make gSender public until I was sure that we had all our bases covered. This included at least a couple iterations on builds for every OS, less reports of crashing and bugs, fulfillment of the big ticket item requests like jogging stability and keymapping, and some refinement in the overall design that was more of a gut feeling.

  2. How does this include the hobby CNC community as a whole?
    If you weren’t aware, the LongMill and many other machines such as: X-carve, Shapeoko, Bob’s. MillRight, OpenBuilds, 3018 CNCs, and more all run on the GRBL open-source firmware. This is what gSender has been built to support. This means that though gSender comes ready out-of-the-box to run a LongMill, it can also readily support many other kinds of CNCs and we’ve made it open-source and free across the board so that anyone can come on over, grab it, use it, and benefit from it. So yeah, tell your friends! No mater what CNC they use, if you’ve enjoyed using gSender then they probably will too :slight_smile:

Alright so, of course I’ll do a quick recap of changes since the previous release and where to download, I just want to say a couple last things first:

  • With gSender now public, this will likely be one of the last communications made to this mailing list as all of you signed up for the duration of the closed Beta which is now concluding. Instead, I’ll likely be moving my communications over to a combination of our website blog and the Forum - we’ve got the regular Sienci Mailing list you can feel free to sign up for if you want to continue receiving development notifications
  • If you’ve enjoyed using gSender, I’d love it if you would take the time to respond back a review of how you find it. I don’t yet have a plan on how I’m going to use the reviews but at the least me and my dev team really grin ear-to-ear when we see you guys getting so much out of gSender so that would be some great feedback to hear
  • Lastly, thank you all so much for taking the time to provide your feedback - the feedback that’s brought gSender to what it is today. There will continue to be a page available for submitting gSender feedback here: https://sienci.com/gsender-feedback/ so keep it coming if you have more to say. I’m so grateful for the time and words from all of you

Okay, on to the normal stuff!

New changes:

  • Improvements to job handling
  • Tooltips created for data entry points
  • Splashscreen tweaks
  • Working PI build!?

Downloads:
All downloads are now available on the gSender page on our website, check them out here!
https://sienci.com/gsender/

There’s also now a documentation page underway, check out the beginnings of it here:
https://sienci.com/gsender-documentation/

If anyone has any further questions or need assistance downloading the new version I’ll be keeping my ear to my inbox and the gSender forum category over the weekend :+1:

Cheers cheers cheers!
-Chris and the rest of the team at Sienci Labs

2 Likes

I have tried to download the Raspberry Pi version twice, once from the link, the other through “other verrsions”
I get the following trying to execute it.

pi@zumbach-pi:~/Downloads $ ./gSender_0.6.4_arm64.deb
bash: ./gSender_0.6.4_arm64.deb: Permission denied
pi@zumbach-pi:~/Downloads $

when I assign Execute privs I get :slight_smile:
pi@zumbach-pi:~/Downloads $ ./gSender_0.6.4_arm64.deb
./gSender_0.6.4_arm64.deb: line 1: syntax error near unexpected token newline' ./gSender_0.6.4_arm64.deb: line 1: !’
pi@zumbach-pi:~/Downloads $

1 Like

Huh, alright will confer with the guys on Monday and get back to you Stephen

Hi folks, I have been laid up the last 2 weeks recovering from neck surgery and see I need to get caught up. Really looking forward to using the latest Gsender. As always Sienci is Top Shelf. Nice work guys.

1 Like

Chris, Tried loading RPI 6.4 deb version on my RPI4B.
Got initial error of Package not installable & to add Arm64 architecture.
“sudo dpkg --add-architecture arm64”
“sudo apt-get update”
“sudo apt upgrade”
“sudo gdebi gSender_0.6.4_arm64.deb”
Error msg during install was Package not installable: libnotify4"
So back to UGS till?
Russ

Haha, my bad guys - I linked the wrong download. This guy here should work: https://github.com/Sienci-Labs/gsender/releases/download/v0.6.4/gSender-0.6.4-armv7l.AppImage

What you’ll want to do:

  1. Download appimage
  2. Right click and go to permissions tab
  3. Make sure “executable” permission is set on the file

We’ll try to fix the .deb process for future so it’s easier to install and maintain

that’s why its called Beta :rofl:

Hi,
Success for the most part. Used a fresh full OS install, copied the AppImage file to the Download directory, changed to an executable & the program loaded. However a lot of error codes came up with it which I will upload a pic of.
I did connect to my Longmill & ran a bit of code on a project that I’m working on (foam test piece). Initial error msg notwithstanding it appeared to run fine. I will run through it’s paces some more tomorrow.
Russ

1 Like

I am getting the exact same thing,

1 Like

Ok, looks like the error is due to the updater trying to run but not finding a new version since it doesn’t exist. Don’t seem to be any other errors. Hopefully everything else runs smoothly :smiley:

Hi, Out of curiosity I loaded the AppImage file onto my RPI3B that has a 7" screen attached. It loaded no issues or error messages other than I couldn’t resize the window so it would fit the screen.
I had a glitch yesterday running gSender on my RPI4B while coming to the end of a cut file. gSender finished the cut & returned to zero X&Y but Z stayed at safe return height. File also showed as 96% done. Had to stop & exit then gSender seemed fine other than losing x,y,z co-ordinates. Noticed a screen flicker when it happened so it may have been a power blip. Will test some more today & see if it duplicates.
Russ

1 Like

I am running latest rev of gsender on a Pi4 8G. I just did a large job and it operated the longmill great. However, the visualizer in the software is running WAY slower than the machine and eventually locks up and I have to restart gSender when the job is done. When I first ran it my screens were going to sleep after 10min and then gSender was locked up but that is now disabled. Any ideas?

1 Like