gSender safe height issuses?

brand new user here. Just bought a used LongMill mk1

after I set X0Y0Z0 wither with the wired probe or manually, if I move the router and then ask it to “Goto X0Y0” it returns to the correct X0Y0, but it leaves the Z at the “safe height” (set to 10mm). The if I jog the machine again and then say “Goto X0Y0” it returns to X0Y0 and leaves the the router at “safe height x 2” (eg: 20mm)
If I do it again, it’ll be at 30mm

if I start a program in gSender, nothing gets carved because Z is at 30mm above the wood

I’ve had other problems with the machine, all related to the Z-axis as well. One carving it did a bunch of words correctly then drew a line across everything, which was not part of the design at all.

If there’s anything you can recommend I read, I’d appreciate it

@short Does your Mill have limit switches installed?

1 Like

No. How would they help this?

@short They wouldn’t. It is just an additional piece of information for those who will try to help.

1 Like

Hi, I’m back after a long time away from the machine and having similar issues again

The crux of it is that I’m carving on the back of a cutting board and the letters on the “zero” side are less deep than the letters on the right side of the machine.

I have the safe height set to 1mm and the router is bouncing up roughly 15mm every movement. I don’t know why or if that’s even part of my issue.

So I re-did a toolpath to only include some of the letters that weren’t deep enough and asked it to go .1" deeper. It didn’t cut any deeper, so I told it .3", no joy. .5" deeper that the initial run, doesn’t look any different.

At this point, it must be that the machine needs adjustment, but no idea where I should start. Re-flash maybe? Ideally, I’d like someone knowledgeable to give me a place to start looking

Here is a video of the machine in action (turn off the volume, I didn’t disable it in the video,… it’s LOUD)

Thank you very much for any hint of what I should look at.

@short First: Did you resolve the issue that you reported back in February?

Now with respect to your current issue, more information is needed.

  1. What CAD/CAM software did you use to create the tool paths?

  2. What post processor did you use to create the gcode?

  3. You mention that you have the safe height set to 1mm. Is this the safe Z height in your CAM software or the safe jog height set in gSender?

  4. What do you mean by “zero side” and “right side” of the machine.

  5. What did you do to tell the LM to go deeper?

  6. What version of gSender are you running?

With this information, I’m sure that someone here will be able to help. Without it, all will be speculation.

original issue still not fixed, but I haven’t been working on it. I reset XYZ to zero after every run

  1. Carbide Create build 652
  2. Carbide Create
  3. Forgot that that exists in Carbide Create, and it’s set to .5" there. I was referencing the “safe height” in gsender 1.1.7 (as seen in attached picture)
  4. my poorly described left side of machine (when facing it) and right side
  5. changed Max Depth in the Carbide Create Vcarve toolpath. Then generated the gcode and loaded that into gsender

@short I’ve moved your post to the Carbide Create board because I am pretty sure that your problems arise from incorrect settings and, with respect, a lack of knowledge of how CC works. I don’t use it, but I just did some quick searches.

For post processor, for example, it seems that you have four choices. None of them are Carbide Create, it seems. You can and should choose grbl mm.

If one side of your carve is cutting deeper than another, the odds are that either you have not surfaced your spoil board or the material is not of a uniform thickness

I suggest that you read the gSender documentation. Specifically, you will see that the safe height setting in gSender only affects when you are jogging the machine. It has no effect when you are running a tool path. The safe Z height then is whatever you set in Carbide Create.

Finally, if Carbide Create is like VCarve, a vcarve tool path will carve as deep as it take to have the carve touch both vectors that the bit is carving between. You can set it shallower, but not deeper. I suspect that is why changing your depth did nothing. Again, I suggest that you read the CC documentation.

Thanks gwilki!
I have surfaced the spoilboard and the cutting board has been run through my thickness planer, but your help has sent me somewhere and I truly appreciate it!

@short I’m glad that this helps a bit. Feel free to post more questions. It’s odd that you are getting different depths across your spoil board.

I just thought of one more thing. If you are running vcarve tool paths, the depth will vary with the width of the letters. So, if you have wider letters on the left than on the right, the letters on the left will carve deeper than those on the right. This is just the nature of a vcarve tool path. Again, I’m assuming that CC works in a similar way to VCarve Pro. You should check the CC docs, though, and not take my word for it.

With luck, someone here who uses CC will jump in to confirm or correct me.