Gsender z height adjustment causing concerns

Ok… I need some help please.
This was not doing this on the previous version of gsender… so I need report an issue.
When attempting to engrave or cut with the laser mounted in front of the router, after setting ZERO for x y z, once I hit the start button it takes the laser all the way to the top of the z rails. Because it is hitting the top, it stops, makes that loud noise that tells you “i can’t go any further.” Drops back down and starts the cut.
However, it is dropping so low passed the actual z zero point. Therefore the laser is approximately 1 in lower than where it should be.
In gsender the only z movement I have is 0.25". I do not see any other options to change.
I attempted to take the laser all the way touching the board before hitting start, but it does the same thing.

Responses…??? lol