gSender Z probe soft limit error

First I want to say I love gSender. I’ve been using all sorts of gcode senders with my Workbee 1510 with the Openbuilds Blackbox and I feel the gSender finally ticks all the boxes.

Now the problem, I understand it’s beta and I am experiencing a few bugs but the one I’m having the most trouble with is probing. I have homing switches for reference. When I run probe it sees my probe and the sequence works until it touches. It lifts back up and throws a “soft limit exceeded” error. It freezes the software and I have to disconnect and reconnect to control the machine again.

I have checked the default Openbuild 1510 profile and all the dimensions match my firmware defaults so I am at a loss.

Thanks in advance to all!!

1 Like

Interesting. I’m wondering if you probe a taller piece of material will you still reach the soft limit when probing? It could be possible that the machine is barely hitting it’s limits just as it’s contacting the top of the probe block

Well, now I’m really confused. I took your advice and wanted to test at a higher point, but first I thought to test XY probe. This worked fine with no issues. Then I tested the z probe at a higher point and that worked fine. So then I proceeded to test, like I was originally, while getting the error. Well no error any longer, at all. No matter who many times I test it is all working now. I don’t know if testing XY knocks the bug out or what but we will see.


1 Like

Wow that’s so odd :open_mouth:

I’ll leave this topic open for a couple weeks and just let me know if you get this issue happening to you again

I’ve run across something similar and here’s what I have noticed. When probing just for Z the Z returns to where it started when the probing is complete. But when you do a XYZ probe cycle the Z is returned to someplace higher than it started from. If I start an XYZ probing cycle high enough (ie thick stock) it will try to retract too high at the end of the probing cycle and crashes into the upper physical stop on my Shapeoko.

1 Like

Hello. Same thing happens with me. have to turn off soft limits at this point. when I try to move X+ or Y+ if I hold down the shortcut key I assigned. it moves X- or Y- only. I am also using a gamepad, and again I get the same results.
The Z probe I think is faulting out because the probe command tells it to go too low in the Z even though you are still good. for example you are close to your Z limit say 10mm above touchplate. I believe the command tells it to travel at most 30mm until it touches. this would trigger the soft limit alarm.

Following up on this and trying to nail down possible causes -

  1. If you have limit switches installed, did you run homing before attempting to run probing?
  2. Are you running the latest firmware (will mention November 8th in startup string in console) or some other version?


7 posts were split to a new topic: Jogging with Soft Limits