Help for a newbie

I’ve just received my Longmill and built it over the weekend and am mega excited to get going. I’ve started UGS on my macbook and can connect to the longmill but nothing happens? When I go to the jog controller its all greyed out. Please help, thanks.

@Teeman Welcome to the group, Tony. I am not familiar with Macs, but in UGS, how do you know that you are connected to the Mill? Can you post a screen cap of UGS in the state that it is in when it is connected?

I figured the little connection icon changing to orange meant I was connected?

This is what it looked like before I clicked the connection icon.

@Teeman Yup, you’re right . You are connected.

What version of UGS are you running? I can’t see anything in the title bar. You want to be running either the August 2020 Platform or newer. If you are running anything older, try a newer version.

By the way thanks for the help. The version was a 2019 but I’ve just updated to 2020 and updated Java. I also noticed if I unplug the USB the connection icon still turns to orange. I’ll try a different machine tomorrow and see if it works. I’ll let you know.

@Teeman When I disconnect the USB cable, if I first forget to click the orange icon to break the connection with the Mill, the icon stays orange. I think that’s just the way UGS works. Once it connects, it does not poll the Mill to see if it stays connected. There were many glitches with the August 2019 version. With luck, the new version will fix your issue. If not, we’ll keep looking. There is a UGS Google user group that may be helpful if the update fails to fix it.

@teeman Also change the Feed rate in the jog controller window to 1,000 (I use 10,000) and the step size XY to 1 or 10 for more obvious movement. Z Axis at 1 is Ok - once you get it actually connected.

Thanks all, tried 3 different laptops on different systems and still the same greyed out jog control window. The mill itself makes some humming sounds like the instructions say it will but I can’t get anything to move using the jog controls or any other button on the interface. @gwilki Will try the UGS google group and see if anyone has any ideas.

@Teeman Tony: I’ve been playing with mine to try to duplicate your problem and I just did.

I am running Windows, so I can just speak generically and maybe you can translate it into mac. Here is what I found. I opened UGS and hit the connect icon. I got the orange “light” and a message in the console saying that I was connected to com1 at 115200 baud. However, all the jog buttons were greyed out.

I went into device manager in control panel and saw that the arduino is connected to com3, not com1.

I went back into UGS, changed the connection port to com3, hit the connect icon. It turned orange and the jog buttons were live.

If you can do anything like this on a Mac, it may solve your problem.

1 Like

Fantastic Grant, one step nearer. I thought I tried this yesterday but obviously didn’t. cu.usbmodem14501 did the trick and the jog controller ungreyed itself. Now to problem 2. If I press any of the direction buttons I hear a repeated sound but no movement in any directions. If I press return to zero the spindle holder goes up and down about 20mm.

Any suggestions would be massively appreciated.

Up your feed rate to 1000, try again…

1 Like

@Teeman Steve has it, Tony. At 10mm/min, it is moving so slow, you can’t see it move. Tony’s suggestion of 1000 is good. I have mine at 2000 because I am not a patient person.

Fantastic. I can’t thank the both of you enough. It moves like a dream.

1 Like

Glad to hear it. Have fun.

LOL Grant, mine is at 10,000…I know it won’t run that fast., but it makes me feel better…