Importing to CAMLab

Up until now I have been using the Carbide Create program for creating my g-code, but like a general consensus here, am frustrated by the line of “M” code generated for bit changes. I have tried to use the CAMLabs program but am unable to get anything to open/import. I have been trying to bring them in from Inkscape. Am I missing a step or using the wrong file formats?

Cheers,

1 Like

Ah yes, CAMLab was made for performing CAM on specifically 3D models (.STL file type). In case you’re interested, I found a fix to the M code issue the other day:

Think I’ve got a reliable solution: in UGS if you go to Tools -> Options -> UGS -> Controller Options then click the ‘Add’ button, a new row will appear in the bottom part of the window. Under the “Regular Expression Pattern Remover” column, you’ll be able to double-click the empty cell to enter in the g-code command that you’d like UGS to ignore, in this case it would be “M6 T101”. Depending on the software you’re using to generate the g-code, you might want to remove the space or change the expression accordingly (ex. “M6T901”).

It’s important to note that this isn’t an issue with the LongMill, it’s an issue with the M6 command support by UGS. If you decide on using a different g-code sender such as bCNC, CNCjs, etc. they support the M6 command by default; we simply recommend UGS due to it’s general ease of use. If you want to see what other options are out there to use as an interface for your LongMill, you can see the page that I put together here: https://sienci.com/dmx-longmill/machine-interface/

1 Like