Laser errors occuring during gantry movement

Laser has suddenly decided to shut off intermittently when gantry makes a move.
Worked flawlessly to start with but now all projects resemble a pen running out of ink.

Gone from ability to create large Star Wars Calendar and photos to inability to sign carved objects.

@mwbeard1957 More info, please, Mitch.

  1. Is this a laser module attached to the LM?

  2. How did you generate the gcode - Lightburn, VCarve, etc?

  3. You say this occurred suddenly. Has the same file run successfully before or is this a new file?

  4. How are you send the code to the LM, if a LM is involved? Directly from LB? Using gSender?

  5. If using gSender, what version are you running?

With this information, I’m sure you will get sound advice. Without it, all will be well-intentioned speculation, IMHO.

Error results using any file.
Sienci Laser on LM MK2 48x30
Latest Lightburn generating Gcode then loaded into latest Gsender.
Have tried multiple lenses, speeds and power settings all with same results.
On close inspection during burn at times when machine does even the smallest of directional changes laser is powered off resulting in an overall blotchy broken outcome.

@mwbeard1957 Thanks for this. To be clear, I am not tech support. In this context, I am just another LM owner/user. With luck, others will jump in with advice.

In the meantime, you may want to read what others are saying about issues with gSender 1.2.0. If your problems started when you upgraded from 1.1.7, the new version may be causing your problems.

Since you have run files successfully, I’m assuming that, in gSender you have set $32=1. Also, that, when you created the project in LB, you had Smax and $30 set to the same value.

One thing you may want to try is to run the file directly from LB. If it runs fine, you will know that the issue has something to do with gSender and the code it is reading.

Thanks for your feedback. The problem started in the previous Gsender and all parameters are as you suggested. I will try outputting in Lightburn if able and see if that changes the result. Strikes me as odd that when watching closely the laser always shuts down for an instant with a change in gantry movement. Not very impressed with Laser operations as a whole but still like to use it to apply logo and such to projects.

Thanks once again!

@mwbeard1957 I’m sure that you know this, but the laser is supposed to shut off during rapid moves. That’s what setting $32=1 does. So, if it is doing that and you can see it doing that, that is not your problem.

Try burning it in LB without involving gSender.

Maybe a dumb answer- did you check the wiring to the laser? The Z axis movement could cause an open, just a thought

Yes sir aware of that. all jobs resemble a pen running out of ink. Wiring is fine also, trying Lightburn tomorrow. Love the system overall and the software packages are excellent! Will nail it down eventually.


On another note - Have you tried using Vectrics module with this laser?

I use Vectric with the Quick Engraving toolpath and the
Jtechphotonics post processor and it works pretty well.

I did buy the Vectric Laser module to do photo engraving but have that up as a bad job …$50 wasted IMHO.

@mwbeard1957 Like @GregM , I tried the vectric laser module. I didn’t buy it, though. I just tried the trial. It gave me nothing that the Jtech post processor didn’t give me, and the pp is free.

I simply set up various “dummy” tools using the laser’s specs. My laser is the 10w Endurance, but what I did can be done for any laser. I can do any of the toolpaths that are available in VCarvePro using the laser. The Jtech post is written for VCarvePro and kills any Z moves. I only tend to use this when I have a project that I design in VCP. Otherwise, I just design in Lightburn and use it to burn the project. I never have really figured out why anyone would design in LB, then output the gcode to gSender. To me, that just adds in another potential point of failure. I know that Ikenna recommends that approach and many do it, so I seem to be the odd man out.

Good luck with your LB test. Please let us know how you make out.

Repeated the test today using both Gsender 1.2 and Lightburn.
Results were identical, seems the system is shutting laser power down with with certain gantry motions.
Got me stumped!
The included image is done with Lightburn exclusively.