Laser function in a LongMill

I thought that I would start a new topic, as my latest issue does not really fit into the other two laser topics.

I have the V2 LongMill controller.

I now have my laser mounted and working - sort of. I am using LightBurn software. I have two issues:

  1. I can do line burns, but I cannot do shading/fill burns. The laser does not power down in those areas that should not be shaded even though LightBurn shows them as red/fast move areas.

  2. I cannot use LightBurn to fire the laser at a low rate to set my 0 position.

Here are the steps that I’ve taken so far to address the problems:

  1. I have uninstalled and re-installed LightBurn. No joy.

  2. I have made sure that $32=1 and $30=100 are set. A $$ command in both UGS and Lightburn confirms this.

  3. I have set the power setting in Lightburn to 100 to match the grbl setting.

  4. I have confirmed that the polarity of the cable running from the PWM terminal on the LongMill controller to the laser drive board is correct.

  5. I have confirmed that there is an M4 command at the start of the test gcode file. This command allows for variable laser power, and should turn the laser off when it is not moving.

I have concluded that PWM is not working. From what I’ve been able to read, this should be the function that modulates the power of the laser so that it can do those things that mine cannot do.

If anyone here has any advice on what else I can do to diagnose the problem, I would be most grateful. As it is now, I’m out of ideas.

Try using a M3 command instead of M4. M4 didn’t work for me, but M3 did.

I feel your pain. In a way I’m glad this issue came up. Not glad you’re having a problem but just in general. I ordered my laser 2 days ago and it has shipped. Hopefully you will have a resolution soon so I will know what to do to when it happens to me.Thank you guys for being the guinea pigs for the rest of us.

Same here - as I mentioned in the other thread. Ordered the same laser on 8/7. That laser does say TTL modulation in the title, but the specs on it show it can do both.

@paullarson I was about to add to my “things tried” list when I read your post.

Just after my first post, I had an idea. It didn’t work, but it seemed like an excellent idea at the time.

In LB, you can choose grbl as your device. That is what I have been using. It sets M4 in the toolpath. However, you can choose grbl -m3. It is supposed to be for grbl versions older than 1.1f. I am running 1.1g, but figured that it couldn’t hurt.

I set my device to grbl-m3 and ran the test. This time, it still burned fill that it should not have, but there was some variance between the good parts and the bad. Now, it gets weird. I realized after doing that test that I had not set $32=1 and $30=100. I didn’t understand that, by choosing a different device, I had to re-input those settings. So, I set them and ran the test again. This time, it was WORSE!. It was back to what it was when I had the device set as simply grbl.

So, Paul tks much for the idea, but it does not solve my problem.

I’m just about to go down to try one more thing. So far, my test files have been .dxf files that I have imported into LB. They have been exported from VCarvePro. I am going to try to create a file from scratch in LB - just a circle and a square. I’ll run it. I don’t really believe it will work, but as this point, I’m grasping at straws.

@Heyward43; @stevendq I sincerely hope that you don’t have any issues. Kris did not and he has the same laser as I do. Andy, too.

It seems to me that it must be one of two things. Either the laser is defective or the Long Mill controller is not sending the necessary pwm codes to the laser. When I enter $32=1, the controller replies with an OK. I can check with $$ and see that it has, in fact, set the laser mode to on. However, I have no means to tell if it really is doing what it should. I understand that I would need an oscilloscope and know how to use it for that.

Thanks, Grant - hope so too. Just been looking through reviews and comments on this Banggood laser and found an interesting comment:

-Don’t even think about powering this up without proper laser protection glasses - this is powerful. When powered, even with no PWM input it defaults to full power which to me is dangerous as it is unexpected. To get it to work with my Shapeoko CNC, I needed to put a 1k resistor from the PWM connection to Ground, otherwise the Laser stayed on full power all the time.

I did find other comments that the laser was not working properly for them, but the reasons were all over the place. Perhaps an email to Banggood on the issue might help.

Will certainly check mine over when it comes - sometime around the end of August - and report back. Still hopeful that a solution will present itself. I have also seen the $30 command should be 255 in many of the googles out there…

@stevendq That’s very good to know, Steve. I’ll have to dig around to see if I have a resistor.

I am going to write to the sender. I can’t expect them to take a return since I’ve lengthened the wires, but they may have had enough feedback that they will have some ideas.

I just tried a simple circle, square file created in LB and the problem is the same. The laser did not reduce power when moving from one object to another.

As for the $30 command, Kris and Andy said set it to 100. LB says to set it to 1000. I’ve tried both. I saw no difference in the problem. I think the key is that, whatever you set it to, set the max power in LB to the same number.

Thanks for this. Back to the drawing board.

@stevendq Steve: I tried to find the post about the 1K resistor on Shapeoko, but could not find it. Do you have any details? Would the resistor be soldered between the + and - leads of the pwm connector, similar to the small resistors being soldered inline on limit switches?

You guys take your time figuring this out. My laser won’t be here until mid-September so you have plenty of time. :upside_down_face:

@gwilki - it was one of the reviews on the laser on the banggood site. Here is the link to the listing page: https://www.banggood.com/450nm-5W-Laser-Engraving-Module-Blue-Light-With-TTL-Modulation-p-1337358.html?cur_warehouse=CN

There was no data other than what I pasted above, scroll down to the bottom of the listing where the reviews are and go to page 10. User BG433938381 left the comment. You can leave a comment to his review and maybe get further info.

@Heyward43 :slight_smile:

@gwilki, I manually set up my device and selected GRBL When Lightburn (LB) generated Gcode it used the M4 command and my laser did not turn on, so I edited the G-code and changed the M4 to a M3. Then the laser turned on when I ran the G-code. So, I edited G-code for a while changing M4 to M3, but now LB generates it with the M3. There was a LB update a day or two ago so maybe that’s when the behavior changed.

I have successfully cut out 1/8" (3mm) BB plywood and engraved/etched it. The G-code does vary the intensity of the laser and I’ve been playing with speeds and intensity trying to improve my results and just learn.

Regarding $30, the only important thing is that whatever you value you put in $30 your should also put in LB (S-value max). They need to match. I used 1000 because I thought, maybe mistakenly, that would give me more resolution in intensity. 100 has the advantage because intensity setting matches percent.

@paullarson Mine simply does not work that way, Paul. I can etch wood. But, it is always etched at full power. So, for example, when I drew a sample file with just an square and the circle side by side, the laser etched the square, then the circle, but there was a burn line between the two. The laser did not power down.

I have set the S-value max to the same value that I entered into $30. I have tried both 100 and 1000. It made no difference.

I don’t know what to tell you Grant.
Here’s a little project I did today just to gain experience. It’s three layers of 1/8" BB plywood cutout and engraved with my laser. I died the middle layer black, then glued them together. It turned out pretty cute.

2 Likes

Just wondering what speed you was able to cut the 1/8 bb plywood? For me to do one pass, I am at 4 inches per minute at 100% power. I have a so-called “7w” diode laser. Trying to figure out if I have mine set up correctly. I also added an air nozzle which helped greatly.

I am in total agreement that the laser powering on full blast when first powered up can give you a scare and burn mark on whatever its pointing at. :astonished: I learned the lesson when Lightburn glitched and I x’d it off and turned it back on. Now I have trained myself to turn the switch off to the laser until I am ready to burn and turn it off when I’m done.

You may have considered this already, but you could try to order a new driver for your laser. I think they are 30 or 40 dollars on Amazon and Ebay.

@paullarson Looks good, Paul.

@bhale Brad: Does your laser have the small button on the board to set the laser to “weak” while you are arranging your piece? Mine does, and when I press it, a small red light does blink on the board. Unfortunately, it does not weaken the laser. I would be interested to know if you have a button and if it works for you.

I contacted Banggood and explained that the “weak” button does not work on the driver board and that the pwm does not modulate the strength of the laser.

They wrote back immediately, asking for a video of it “not working”. It’s pretty tough to video a negative, but I am going to try. I figure that I will put a piece under the laser, turn the laser on, and show it burning. Then, I will repeat the process with the “weak” button pressed and show the wood still burning.

I’ll report back. At least they are communicating. Since I have lengthened the wires, I don’t expect a free replacement.

1 Like