Laser Not Firing

I just received the new Laser Module and got it setup on the 30X30 long mill. I had previously had a NEJE laser installed which was excellent for engraving but would not cut. I am using lightburn and the X and Y axis will move fine when I run a job but the laser is not firing at all. I even tried test firing the laser and nothing. I set $32=1 and $30=100 and installed code M3 and still nothing. The baud rate is set to 115,200. I have spent hours trying to get it to work and it is getting frustrating at this point.

How did you setup the Longmill in Lightburn? I let Lightburn look for the Longmill and it automatically set up the connection.

If you haven’t already connected this way, click the “Devices” button in the laser panel and then click “Find My Laser”.

Was no problem for me. Hope t his helps.

Ron

@clark77494 If you set $30 to 100, SMax in LB must be set to 100 also. Is it?

1 Like

I found what the issue was. The DIP switch needed to set to 4 in able to have the laser fire. This was not in any of the documentation. Now the laser is out of focus which I will tackle tomorrow. This is what it is doing during a test fire.

Still waiting for my Laser to arrive but when it does I plan on using Vcarve Pro Laser module and UGS. If using Vcarve Pro should I set $30=100. In Vcarve I do not see an S value like you can set in LB.

Lens in installed upside down. End with the slot cut in goes down.

Just watched sienci laser demo video and UGS setting for $30 should be 255. I see in LB there is a field to set the S value to 255 so they match but don’t see an equivalent setting in Vcarve pro. Is anyone currently using Vcarve pro with Laser module with UGS. If so can you please let me know the settings you used.

Hi guys, this seems to be a pretty common issue, normally due to some weird setting. I’m also having the problem of no laser firing, right out of the box. $30, $31 and $32 values are correct, the dip switches are right, and I’ve tried everything with the reset button, and nothing. The LED in the box comes on to say there’s emissions, but the diode wont visibly fire anything at all. Any ideas? Did I just get a lemon?

So? the end with the slot goes into the laser or goes into the knurled knob?

Check the Assembly video from Dana at Bucky’s Customs.

Bucky’s Customs Assembly Video

At 14:48 he talks about the reset button and how it needs to be pressed before getting the laser to fire.

At 16:40 he talks about the lens assembly.

The slotted end should go into the focus adjustment ring, then the spring onto the lens, then the whole thing screwed into the Laser body.

1 Like

Does the toggle switch and lockout keys come after all input from the control board? It seems like even if they’re off the operation is the same. I can’t get laser firing even with the reset button. Is there an order for everything to be turned on? Does the reset button need to be held for a significant length of time?

I pressed the reset button. The laser emission LED is lit, so there are two lit LeDs on the control box, but no beam. Doesn’t that LED mean that power is going to the diode and it should be firing?

@MikeKoning I haven’t installed mine yet, but watching some videos and reading about the LaserBeam, the only thing I can think of, with my meager brain power, is make sure your Dip Switch setting has one toggle in the down position: Switch 1 for 1 amp, Switch 2 for 2 amps, etc. up to Switch 5 for 5 amps. No more than one switch can be down at a time. Otherwise if you are still having issues, you may want to contact Sienci for help.

1 Like

I’ve tried dip switches 1 to 4 independently with no result. I haven’t heard any response from reaching out to Sienci yet, but as my past experiences have been nothing but positive, I’m hoping this will be resolved.

All I want to know now is if the laser Emission LED means that yes, the diode is receiving power. That would confirm that it’s a diode problem.

1 Like

The only other thing I can come up with would be the wires going into the green connector plugs could be loose (screws not tightened on the connectors).

I am sure Sienci will get back to you. Good Luck!

I might have narrowed down something - I am following the procedures for how to do a reset with the reset button. I should have everything plugged in, and then turn the driver off, reset, and turn the driver back on via the toggle switch,

When I plug the driver in, it lights up and the fans spin. When I turn the toggle switch to off, it stays lit and the fans stay spinning. It seems to me that the board is constantly powered and maybe the switch is wired wrong? Could that be preventing a reset?

Currently, LED powers on, fan spins, and even if the key is turned off, the interlock is removed or the toggle is turned off, the driver stays powered on and spinning. I am wondering if this is normal or if this is something wrong and preventing me from a reset. I would love to know if other people’s drivers mimic this behavior