Laser stopped working all of a sudden

I tried to make a quick burn on one of my projects this week and the laser won’t burn anything. I used it fine last week and when I press the test button it does burn the wood, only when I run the gcode it doesn’t. Any one else running into this issue and if so is there a fix?

@casualit I deleted your duplicate post. The obvious question is what changed between last week and this week? :grinning:

What program are using to generate your gcode?

The question you’re asking is actually not obvious since nothing changed at all, the same file I used last week is not working this week. I use lightburn to generate the gcode.

I’m not sure why it has power when I press the test button but no power at all when I run the gcode.

@casualit My apologies if that came off as being sarcastic. That was not my intention. However, if nothing at all changed, the file would still run. I’m not saying that you intentionally changed anything.
For example, in Lightburn, what do you have Smax set to? Then in gSender, what do you have $$30 and $32 set to? Finally, if you run the job in LB, does it run properly?

Apologies as well, I’m just a bit annoyed that this $400 add-on did not last me even a year. The $30 is set at 30000 rpm and 32 is enabled. The laser power in the config is set at 255. Lightburn set at 100% power and it does show the right results in the preview.

@casualit No worries, C. However, you have identified the solution. $30 and Smax must be the same. So, if you are setting Smax to 255 in LB, you must set $30 to 255 in gSender. If you don’t, strange things will happen. :grinning:

Interesting, I’ll try setting $30 to the same number, isn’t that going to affect the router when I’m not using the laser?

@casualit If you are using a router, it has no effect. You cannot control the router speed by gcode. If you are using a spindle, then it comes into play. That’s why gS has a spindle mode and a laser mode.

I’m going to be off air for an hour or so. If you pose a question, I will get back to you then.

No I think I got it, thanks a lot for the help, I’ll update this thread with whatever happens when I get the numbers the same. Cheers!

1 Like

I haven’t run a full job yet but after updating the numbers I saw that the power is back for the few seconds I ran it. Now I’m wondering how it was working up to this point?
Hmm now it’s too much power haha, I guess I can deal with that better!

@gwilki Something is definitely not right with the laser, it has power but now the Fill and Line are not working like they used to. The Fill is just black even when I set the max power to 10 on LB. The Line is just not lining all the letters. I’m at a loss and maybe thinking the laser unit is malfunctioning.

@casualit It could be that the laser is bad. However, there a couple of things to look at before concluding that - in no particular order.

  1. When you set Smax and $30, did you set them both to 255?

  2. I know that I am repeating myself, but $32=1 is set?

  3. Have you tried to run the job from Lightburn or have you only tried it by running gcode that you exported from LB to gSender? If the latter, I would suggest that you run it from LB directly. If that works, at least you will know that the laser is OK.

  4. How are you focussing the laser?

  5. Can you post your lbrn file?

  1. Yes I did, now it has power unlike before
  2. Yes it is set.
  3. No I have LB installed on my beefy PC and run the jobs from a laptop connected to the CNC
  4. I just follow the steps I found in the this video:
    5.I tried a few things but now I’m just trying a simple file to Fill and Line some words. (66.8 KB)

@casualit Since this is a newish issue; that is, the laser has worked well before, I am out of ideas. Ideally, I would like to see the .lbrn2 file - not the .nc file that you sent to gS. I understand that you cannot run the LB file, but it’s always best to try to run from the source application. The LB file may show something that the gcode does not.

Again, I understand that you have had successful laser projects before, but one thing that your .nc file shows is that you are setting to mm/sec. Lightburn’s recommendation for diode lasers is to use the mm/min setting.

Others here may have some ideas. I keep coming back to trying to determine what has changed from when you had successful projects. You may want to open a support ticket with Sienci. Their techs know much more about this than I do.

@gwilki One more thing, I noticed that the Driver is not doing some of the things it used to, like for example the little switches that set the power when I change it to 1 it still puts way too much power, also the called “dummy faults” built in are not triggered when I change to power settings like it used to do, so maybe the box is not working properly which may explain why nothing changed but the laser is not working?

@casualit Could be. (I know that’s no help.) I don’t have the Sienci laser module. I know about the dip switches and their function, but I can’t try to replicate your issue. With this new information, if I were you, I would write to Sienci support.

Thank you Grant I appreciate the help!

@casualit You’re welcome. Sorry we couldn’t get it fixed. Please report back when Sienci has solved this.

1 Like