Light Burn issue

When I try to run G code created by light burn the mill doesn’t move. Im using GSender. The image shows up in visualizer, it shows the laser moving., the laser fires, the DRO numbers change as if the mill is moving but it is not. Just burns a single dot.

I tried the same image with LaserGRBL and everything worked fine. I have lightburn set to GRBL, the code looked ok as far as I could tell.

Any suggestions out there?

1 Like

Did you happen to make the change in Gsender to let it know you have switched to Laser?

See timestamp 5:07

Yes it is in laser mode and changed the $30 & $32 as another member posted on the forum. I’m stumped, I’ve seen the machine act like this before when I broke up some gcode for a router project and deleted the G90 and G20 code at the beginning.

@CraigN Can you post the gcode?

I can’t upload here as a new user. I replied via email, hope that works as I am new to using the forum, but have gained a lot of knowledge following it.

This is the first few lines in case the attachement doesn’t go through.

; LightBurn 1.0.06
; GRBL device profile, absolute coords
; Bounds: X27.02 Y23.02 to X114.09 Y102.08
G00 G17 G40 G20 G54
; Cut @ 236.2205 in/min, 20% power
; Layer C00

1 Like

@CraigN I did not get the PM with your file, but the gcode lines you posted look OK,other than the speed setting. The Mill will not move that quickly unless you have changed the default speeds. That should not be causing your problem though.

I would start by changing $30 back to 3000 and $32 back to 0. When I suggested otherwise in that other thread, I wrongly assumed that the member was running the project from LightBurn.

Try those two changes and let us know if they help.

Made the changes, no luck.

@CraigN Have you tried running the project in LightBurn, rather than exporting the gcode to gSender?

FWIW, that would be my next step. If it runs, then you will have reduced the issue to one of gSender running the code, and not a problem with the code itself.

If you want to try it, in LB console, you need to enter $32=1. As for $30, I use 1000, but I know that Ikenna recommends 255. Either will work. Whichever you choose, you need to enter the same value in LB in the S Max field.

If you prefer to keep trying using LB to write the gcode and gSender to run it, I can try it for you, but I need the entire gcode file as exported from LB. I have sent you a PM with my email address. You can email me back with the file if you like.


With Grants assistance I was able to isolate the problem.

The cut window in light burn had the “air” enabled which I assumed was correct since the Sienci laser came with air assist. With that enabled it put M8 commands in the g code which the machine doesn’t seem to like. Once I turned that off it replaced it with M9’s which did not affect machine function. Runs fine now and the laser works great. Seems like another good product so far.

Thanks Grant.

1 Like