Longmill Pausing in UGS

Hello!

New Longmill user here, been quietly browsing forums for many months and got my Longmill back in December.
I’ve been experimenting a bit more lately and have noticed that UGS pauses on me; not all the time, but enough to cause concern. It goes to a yellow “HOLD”.
Sometimes when it does this it seems to skip a spot, sequence or step. It has cut through a tab on a box drawer that I made, missed a hole from a drilling tool path and possibly puts things out of alignment (not sure on the last part).

It does the same with vacuum on or off, so it seems I could possibly rule out static. I’ve loaded all the Longmill settings into UGS as well.

Has anyone else had this issue? Any thoughts on a resolution?

I’ve also contemplated CNCJS, but can’t find a good tutorial on how to get it setup.

Any help is appreciated.

That seems to be a long going issue with UGS. Some people run it fine with no problems but some have constant issues. Number one thing to check is your computer. Turn off (“Never”) any sleep or power settings that can put your computer to sleep. Go into Device Manager and turn off power settings in your USB devices. These are just a couple of things that might help. As for CNCjs it is very similar to UGS in appearance and operation. The only thing I had to set up was a macro for using the Sienci touch plate but there is a sample on GitHub. IMHO it has a better visualizer than UGS. Other than that they are pretty much the same.

2 Likes

All my power settings are correct. Maybe I’ll try cncjs tomorrow.

Did you drop in the same settings for thr longmill that UGS uses? Or just run as is (with addition of touch plate macros)

Pretty much plain vanilla except for adding the macros. Same connection settings. Arduino uses same data as provided from Sienci.

1 Like

Randomly? If it is always between two different tool paths -> M6 tool change commands in the GCode

1 Like

Thanks! I’ll try it out this weekend.

And yes randomly. Sometimes it will pause right after the first second of movement, sometimes it is after a few seconds. Once it happened after about 5 mins…so I’d say pretty random.

@Dlab006 If you are running windows, make sure that all the power saving settings are turned off, including the one that allows windows to play with the power going to the USB ports.