M0 pop-up stays

I noticed that when I run a macro I get a popup that times out and closes. Not so with the M0 message. It stays unless you manually close it. More of an annoyance than a functional liability. See screenshot.

Thanks,

Jim

1 Like

I was running into this yesterday as well. After closing the warning I wasn’t able to use the jogging arrows to move the machine unless I disconnected and reconnected my machine. I was actually looking to see if anyone has come across the same issues.

Thanks,
Drew

Same here. I went back to 0.6.8

I didn’t have the jogging issue that you mention. Are you using Windows opsys?

yea win10 x64. I don’t no if I have to change a setting somewhere it was actually my first time using my machine so it could have been a user error.

@DLare @DrewBSC @jelanier how are we looking with this for the newest 0.7.2 release?

Hey Chris,

I didn’t update gSender this week but was using 0.7.1 and it still comes up. Wont be on my machine till next weekend so I cant give an accurate update till then.

Drew

1 Like

Hey @chrismakesstuff,

The M0 pop up with still present with 0.7.2 just instead of it popping up 3 times in a row it pops up once. Basically you load the project you hit start, the machine makes a quick move then the error pops up. You wait 5 seconds and hit resume and you don’t see the error again. Must be something in the CC program, its nothing wild.

Here is the first 10 lines of the program I ran yesterday and the error popped up.

G90
G20
(VCarve.To…)
M05
M0 ;T301
M03S18000
G0X5.1428Y-15.5249Z0.3937
G1Z0.0000F20.0
X5.2037Y-15.4794Z-0.0363F40.0
X5.2835Y-15.4184Z-0.0500
X5.2823Y-15.4052

1 Like

@DrewBSC CC inserts the M0 command for some reason. It is a stop comment in grbl, so your machines stops. I believe the newest version of gSender pops up an error, which remains until you close it. Is this what is happening on your Mill? One way around this, if you want to edit your gcode is to simply delete the M0 line in the code, then re-save it.

Okay, yeah that’s pretty expected behaviour. Myself and the team have a new idea on something we’ll be looking to implement where we can detect(?) carbide create files and skip their pause-on-start feature that they have for some reason. Will keep you updated if the change goes through

Hey Grant,

That is exactly what I have been doing and no issue. Just trying to help the CC users out, but really after my year subscription is up I will be moving onto something else. Really starting to feel limited with the program.

Drew

Hey Chris,

Its not a big deal, if someone is having an issue with CC send them my way or suggest what @gwilki said. Personally I would steer people away from CC as I find its limiting the full potential of the longmill. Especially when it comes to using profile bits the previewer is not accurate and leaves you guessing what’s actually going on unlike VCarve.

Thanks
Drew