M8 nut not fitting in 3d printed part (assembling help)

Hi, I just got my machine today:) But I’m having really hard time trying to fit M8 nut into 3d printed part as described on page 24 of the assembly manual.
I’ve been trying various methods for an hour straight and these two nuts just won’t fit. I only managed to push one about 1/8" in. I don’t want to break the plastic
Did anybody have this problem?


I am having the same issue - hoping someone has a tip on how to get these in.

I wish I could share an easy solution to this problem… I just assembled my machine yesterday and I spent an extra hour with a dremel tool and a small file carving out those holes until I could press the nuts in. Every other step of the assembly went pretty well, but this part needs a little more QC.

I assume you are talking about the 3D printed Z axis mount. I broke mine trying to force the bolts in. Fortunately I have a printer so I made a replacement and the bolts didn’t fit in that one either. I heated up the bolts with a heat gun and pressed / melted them in.

Thanks for the tip - I did the same thing.

I solved my M8 fitment problems by taking the nuts to my 12" disc sander. I ground off a bit off each of trhe 6 faces until they dropped in like they were made to fit.

Just make sure you don’t go overboard with the removal to the point where they’ll spin around in their holes.


No answer from Sienci? I don’t have a grinder or the means to super heat the bolts to melt them into the plastic… I’ve been stuck at this spot for a bit as well.

UPDATE: I’m back from the Sienci support page on the website… and the Facebook group. It turns out that Sienci sends out nuts that are apparently .54 in size but the hole only fits .50.

Some suggested going to Home Depot and 70 cents later (including tax) I have 2 8mm metric (obviously) nuts… and they both fit!

Two hours later I’m back on track. According to some posts, things go smoothly up to and after this step. Fingers crossed!


It’s rather intriguing to me that the Siecei Labs team didn’t get back to you regarding what is such a basic issue. In similar fashion to those who ground the nuts down to size, I used my sander to do the same thing. A file would have also worked. But having the correctly sized nuts would have been a better way to go.

Marty from Kingston, ON, Canada

1 Like

I’m having the same issue. HD is closed :frowning: I guess I’ll have to pause assembly till tomorrow. Kinda frustrating. Everything until now has been great!

UPDATE: I found some M8 nylock nuts in my garage which fit perfectly. Hope there isn’t an issue using locking nuts.