Making a library of surfacing toolpaths

I think my next project is going to be making some coasters with small scraps I have laying around. I’m going to be making some that are a chaotic end-grain pattern, in part to learn the technique so that I can put it to use on bigger more expensive lumber for cutting boards.

Since the panels I’ll be gluing up are too short to run through my planer, I was thinking I could surface the panels at the CNC. I surfaced my wasteboard simply by jogging the machine, and that was ok, but tedious.

Is there an easy way to setup a surfacing operation in Carbide Create, or another CAM app? If another app, which would you suggest? I’d love to build up a library of different surfacing toolpaths saved for different dimension panels and depth of cut so that I could just load up the best one for what I’m surfacing, and let it rip, er, surface.

1 Like

Andy posted instruction here:


Fantastic, thanks! I actually am subscribed to their youtube channel but this was published before I built my Longmill, and I forgot that I had saved it to my CNC resources playlist.

1 Like

Adam: In addition to the method that Andy posted, if you have VCarve, you can simply open a new file, make the piece size 30" x 30", draw a rectangle around it, then create a pocketing toolpath at whatever depth you want. Make your x0y0 the front left corner of your spoil board. Then you can jog your machine to that corner and run the Gcode.


I tried using the app Andy uses but when I try to use the gcode it errors when running in UGS. Anyone had similar?

@Teeman What error do you get in UGS?

Does it run at all?

I’ve not used it, but I just did an air cut, having created the file with it, and the code ran fine.

Just ran out to try it and it ran which it didn’t before. I’ll try it tomorrow with a bit and zeroed properly. I may have only needed a restart. Will let you know.

I was wrong, I created a pocket in Carbide Create which is what I tried and thought worked. Didn’t like the way it spirals from the center. When I run the G code from intuwiz I get the following error

Problem opening file: Multiple F-codes on one line.

I’ve saved it from TextEdit as a RTF file with the .NC file extension

@Teeman You’ve lost me. When you create the gcode in inutwiz, save it as a txt file. Import that into UGS. I don’t understand your reference to textedit and rtf files. I thought you were trying to use intuwiz.
I did a test using intuwiz and simply saved the file as a text file, then opened that in ugs. It ran fine. I’m sorry, but I don’t think that I can be of any more help, as I cannot re-create your problem.

In Andy’s video he copies the code from Intuwiz to notepad. On a mac we use textedit and not notepad although they function the same. I assumed that the file extension should be .nc as other gcode I’ve generated. I’ve tried .nc , .txt but get the same error.

@Teeman Gotcha, Tony. I forgot that you were using a Mac. That may be the problem, but as I use Windoz, I can’t duplicate it.

I would strongly suggest forgetting inutwiz and simply creating a pocketing tool path in Carbide Create. I had not heard of Inutwiz before trying to help you. I simply created a pocket toolpath in VCarvePro, with dimensions just smaller than the max of my Mill and a carve depth of .001. If one pass does not level the spoilboard, I simply run it again.