New MK 2 30x30 Computer won't connect

Hi. I’m new to longmill having just bought a MK 2 3030 macine. I’ve reached the point in the assembly where I connect the computer and in the upper left corner od gsender I just get a little orange wheel spinning. I’ve changed cables and usb ports. Nothing. I tried with UGS and it won’t recognise the machine either.
I’ve upgraded from a 3018 machine and it works fine with this computer. Did I get a bad controller?

1 Like

@KenA Hello Ken, and welcome to the forum. I am only a few weeks ahead of you. Honestly, I never got my Windows based laptop to connect to my LongMill. Have you tried GSender? It is Sienci Labs own controlling software. I am currently using an old MacBook Pro and it works fantastic. I am sure someone here will be able to assist you further. Do you have the RED light and the Ops Button extended outward?

I hope someone with more experience will pipe in and assist.

Hi, Jake. Yep, the button is out and the red light is on. I downloaded the gsender from the sienci sight and tried it first. When that didn’t work I reied UGS which I was using on the 3018 mchaine and it can’t fine the Longmill either.

Well heck… That is the extent of my troubleshooting for this. GREAT group of folks here. Someone will jump on this and help you troubleshoot more. If nothing else, the Sienci team is amazing and very willing to help. Sorry I couldn’t be more assistance to you!

Thanks, Jake. Appreciate you taking the time.

1 Like

What is the computer and what operating system?

Did you install the Arduino drivers?

1 Like

Hi Ken

Put a ticket in with screenshots of gSender trying to connect to the controller.

Open device manager and look for the Arduino Uno under the com ports when you are connected to the controller.
I’ve linked to our resource page. CNC Issues & Fixes 🩹 - LongMill MK2 CNC with other options to try.